summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-03 05:23:32 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-03 06:32:49 +0100
commitd80da0aa1cd91532e592513b8fb199e2944cb52d (patch)
treeb3c0fef725712bf3501f72812ee62dd21023536c /dev-python/crashtest
parentdev-python/spyder-kernels: Bump to 2.4.0 (diff)
downloadgentoo-d80da0aa1cd91532e592513b8fb199e2944cb52d.tar.gz
gentoo-d80da0aa1cd91532e592513b8fb199e2944cb52d.tar.bz2
gentoo-d80da0aa1cd91532e592513b8fb199e2944cb52d.zip
dev-python/crashtest: Bump to 0.4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/crashtest')
-rw-r--r--dev-python/crashtest/Manifest1
-rw-r--r--dev-python/crashtest/crashtest-0.4.1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/crashtest/Manifest b/dev-python/crashtest/Manifest
index 683df081a5e5..fb4279de071b 100644
--- a/dev-python/crashtest/Manifest
+++ b/dev-python/crashtest/Manifest
@@ -1 +1,2 @@
DIST crashtest-0.4.0.gh.tar.gz 13564 BLAKE2B 9c29694f5c96a981e19cce16853460cfed7277a2a933c14be9bdefcac9f79e9d835454fd79b3da2fb5f62946f933452202eee05199dfa048b919a3fc3dd93f40 SHA512 98d9623eeef584baed7bd336a3846af9b4f3aa55662b643e915b17b0a7dce4968785052ce3d37f55fc0217dbb6662b6f5d34efeb4d45dbace876551871be4e4a
+DIST crashtest-0.4.1.gh.tar.gz 19114 BLAKE2B aa46efb2dbabfeaab54f9149da42cb033f5dca3ab1c75032ca2542018058cf16775f56450cadf3e1272e738d602f32f21b9a6668a99f2733cd53d23c1754a0bc SHA512 83faf66fb422c8fb13780ac5a8ddd4c47ebb77f248bea0eb94962caff24265b107fd8bbc0d577853969c4aecedd83977e9c74c81dc7e772b7684e09a832a0a2f
diff --git a/dev-python/crashtest/crashtest-0.4.1.ebuild b/dev-python/crashtest/crashtest-0.4.1.ebuild
new file mode 100644
index 000000000000..a51cf7380836
--- /dev/null
+++ b/dev-python/crashtest/crashtest-0.4.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library that makes exceptions handling and inspection easier"
+HOMEPAGE="
+ https://github.com/sdispater/crashtest/
+ https://pypi.org/project/crashtest/
+"
+SRC_URI="
+ https://github.com/sdispater/crashtest/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+distutils_enable_tests pytest