summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-30 17:00:11 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-01 12:13:20 +0100
commita1d0a674d36d41e2adbeebf5a7f11eb4bf71ee24 (patch)
treef266d7f0499f975a48f6e08424abbd20ec06653b /dev-python/cryptography
parentdev-python/cryptography-vectors: Version Bump (diff)
downloadgentoo-a1d0a674d36d41e2adbeebf5a7f11eb4bf71ee24.tar.gz
gentoo-a1d0a674d36d41e2adbeebf5a7f11eb4bf71ee24.tar.bz2
gentoo-a1d0a674d36d41e2adbeebf5a7f11eb4bf71ee24.zip
dev-python/cryptography: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/cryptography')
-rw-r--r--dev-python/cryptography/Manifest1
-rw-r--r--dev-python/cryptography/cryptography-1.2.2.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/cryptography/Manifest b/dev-python/cryptography/Manifest
index 3f117e86f2cf..73bcde0eae74 100644
--- a/dev-python/cryptography/Manifest
+++ b/dev-python/cryptography/Manifest
@@ -3,3 +3,4 @@ DIST cryptography-1.1.1.tar.gz 348988 SHA256 2912923af7455fb2d2439a037242507c12c
DIST cryptography-1.1.2.tar.gz 349022 SHA256 7f51459f84d670444275e615839f4542c93547a12e938a0a4906dafe5f7de153 SHA512 566e346a76cfd6b1c6afbf64d1fe496770b1ad5f471c42877ad6931a441ab77408815ae066ba3f0450766c86ae9dd10d7a5966321f93a979a4e1ab9e1201371b WHIRLPOOL 9a552e65047c45e19e313e0530031fa282aec51577bcc64f9346f37ac99663db052f7ccc1798532103edffa6e778f9585e937a862a475f6d7bd9140d06bbcf57
DIST cryptography-1.1.tar.gz 348676 SHA256 059bc6428b1d0e2317f505698602642f1d8dda5b120ec573a59a430d8cb7a32d SHA512 8d5b5ac7cc2dcf7271dcd85c65c42cd815b95ec8502864da1b7c32c4a5905ecc6ae45f54d11e7b539d9ddf10d8bd3de9f40233c0b3cbdd1132b2ffbd4ebb318f WHIRLPOOL 0f154e624a51ebbc342ea082fc00a66b21024c81f3265e7d0e22e089afc5e83dcfe2857113d911db3a8e253d6fe93413ff94b91a83e97fd9405c3f08becc8a03
DIST cryptography-1.2.1.tar.gz 372763 SHA256 a13217a03a47e743d26edff7299e4be7358c2fd12a223ac5d6de3229690b6ee5 SHA512 8ec01e23cfc4c6f9dd38a4a3238a670e68e0174e23d815a3babe37b3355cd453586ee271848f5d9d194f6b3b28483101558376e062ef7bb20cc4508261eb1ad7 WHIRLPOOL fa11a9e8ee9c675c0d8d282f420d072e4029e349df5c07202cfd93fcfb94834a0481e2f858f1426b0aba46bf173843ff40975a23d5b006583241f64442307638
+DIST cryptography-1.2.2.tar.gz 372894 SHA256 3f219cb9106d9b737ea9c332c4d15d70ac328f91b59fd9d79f78bdea8f826a67 SHA512 9c838e116b23bf22c5b01ecdd6f7fa0c4c92ce857516d500b983ae71bab002331cafcb404caa454362878ecbe4a818626c5f94636340bcad0518390671a36845 WHIRLPOOL 29c86d3d6f271f5a9a5da9afa39acc49c579e752e2c040e4b1014c0446a4604fa955ff2a6486ed1c0389fbe5ca54c3181af0bcef279a3fd4e8f4a37e3e09c190
diff --git a/dev-python/cryptography/cryptography-1.2.2.ebuild b/dev-python/cryptography/cryptography-1.2.2.ebuild
new file mode 100644
index 000000000000..ae9dbd1f7e97
--- /dev/null
+++ b/dev-python/cryptography/cryptography-1.2.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Library providing cryptographic recipes and primitives"
+HOMEPAGE="https://github.com/pyca/cryptography/ https://pypi.python.org/pypi/cryptography/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 BSD )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="libressl test"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ $(python_gen_cond_dep '>=dev-python/cffi-1.4.1:=[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 python3_3 pypy)
+ >=dev-python/idna-2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.8[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=virtual/pypy-2.6.0' pypy )
+ virtual/python-ipaddress[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
+ test? (
+ ~dev-python/cryptography-vectors-${PV}[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/iso8601[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( AUTHORS.rst CONTRIBUTING.rst README.rst )
+
+python_test() {
+ py.test -v -v -x || die "Tests fail with ${EPYTHON}"
+}