summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2016-09-10 22:21:55 +0200
committerDirkjan Ochtman <djc@gentoo.org>2016-09-10 22:21:55 +0200
commite526924fb64e573cb32a1912bafe21d6b7faa7db (patch)
treebf2aa3ca3ced6e8787d012a9d5317296963dffb0 /dev-python/cryptography
parentdev-python/cryptography-vectors: version bump to 1.5 (diff)
downloadgentoo-e526924fb64e573cb32a1912bafe21d6b7faa7db.tar.gz
gentoo-e526924fb64e573cb32a1912bafe21d6b7faa7db.tar.bz2
gentoo-e526924fb64e573cb32a1912bafe21d6b7faa7db.zip
dev-python/cryptography: version bump to 1.5
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/cryptography')
-rw-r--r--dev-python/cryptography/Manifest1
-rw-r--r--dev-python/cryptography/cryptography-1.5.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/cryptography/Manifest b/dev-python/cryptography/Manifest
index c38ad3ab9777..a700e3704ce7 100644
--- a/dev-python/cryptography/Manifest
+++ b/dev-python/cryptography/Manifest
@@ -1,3 +1,4 @@
DIST cryptography-1.1.2.tar.gz 349022 SHA256 7f51459f84d670444275e615839f4542c93547a12e938a0a4906dafe5f7de153 SHA512 566e346a76cfd6b1c6afbf64d1fe496770b1ad5f471c42877ad6931a441ab77408815ae066ba3f0450766c86ae9dd10d7a5966321f93a979a4e1ab9e1201371b WHIRLPOOL 9a552e65047c45e19e313e0530031fa282aec51577bcc64f9346f37ac99663db052f7ccc1798532103edffa6e778f9585e937a862a475f6d7bd9140d06bbcf57
DIST cryptography-1.3.1.tar.gz 383852 SHA256 b4b36175e0f95ddc88435c26dbe3397edce48e2ff5fe41d504cdb3beddcd53e2 SHA512 8b833619d0aec5e6630c8e069e886f6b708b0b3a4f4ca4e37797a24c69be4cacf162f20c068deaecc3222ee0323583582d384e49fa3dbaeaeefc0d7d8c92918a WHIRLPOOL f9e7c75e910699afdf4adc4fb7257135b97c357c967bbca95f332e1f2ed262716ebba6a648427f86a524e75f6ac46aea7f891fe42100c9d7cf8ffcc317fb7905
DIST cryptography-1.3.4.tar.gz 384109 SHA256 423ff890c01be7c70dbfeaa967eeef5146f1a43a5f810ffdc07b178e48a105a9 SHA512 abbc027433658702d2331282c9f63d99ea2eb42f5cdfe066b2b0ae6d9b86a35e23891716bb2e9e2ca707aa0d38fb69cba22ec5d95d2b9073047444fdae7a9224 WHIRLPOOL 5bd007cfe304620a7237b0f63fbe87ab22bd1cc252941f4815398382122b1c56c5a22e2dc35ce86aba2c2b2d9403de3313bafde23a3695bd26e4eb0f23c9dea9
+DIST cryptography-1.5.tar.gz 400318 SHA256 52f47ec9a57676043f88e3ca133638790b6b71e56e8890d9d7f3ae4fcd75fa24 SHA512 762b313296baf8ec6eb86557a844065022b83a623c7babc374bd63f575085dc845611c385df870050a2633d6b8c6c8399d8470647328b8f2ff44b17937a04756 WHIRLPOOL 8c37b57703961e911c59d0d396c86b83322564506bd80a66b38c068c8e3e018421eeede6a2dda7718b2f134aafc0327b4525eacb9bfa8714c225babed50045ed
diff --git a/dev-python/cryptography/cryptography-1.5.ebuild b/dev-python/cryptography/cryptography-1.5.ebuild
new file mode 100644
index 000000000000..eaee8d2e54b7
--- /dev/null
+++ b/dev-python/cryptography/cryptography-1.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Library providing cryptographic recipes and primitives"
+HOMEPAGE="https://github.com/pyca/cryptography/ https://pypi.python.org/pypi/cryptography/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 BSD )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="libressl test"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl )
+ $(python_gen_cond_dep '>=dev-python/cffi-1.4.1:=[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 python3_3 pypy)
+ >=dev-python/idna-2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.8[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=virtual/pypy-2.6.0' pypy )
+ virtual/python-ipaddress[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
+ test? (
+ ~dev-python/cryptography-vectors-${PV}[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/iso8601[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.9.0[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( AUTHORS.rst CONTRIBUTING.rst README.rst )
+
+python_test() {
+ py.test -v -v -x || die "Tests fail with ${EPYTHON}"
+}