summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-11 11:40:25 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-11 13:24:29 +0200
commitf26c58019bc5f6e6cd268865d09f8e529c22e8ce (patch)
treeecaae5f9cf4ac24d6e7ad7d524ff62cdf2b157de /dev-python/cryptography
parentdev-python/chardet: Add python3.5 support (diff)
downloadgentoo-f26c58019bc5f6e6cd268865d09f8e529c22e8ce.tar.gz
gentoo-f26c58019bc5f6e6cd268865d09f8e529c22e8ce.tar.bz2
gentoo-f26c58019bc5f6e6cd268865d09f8e529c22e8ce.zip
dev-python/cryptography: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/cryptography')
-rw-r--r--dev-python/cryptography/cryptography-1.0.2-r1.ebuild47
-rw-r--r--dev-python/cryptography/cryptography-1.0.2.ebuild2
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/cryptography/cryptography-1.0.2-r1.ebuild b/dev-python/cryptography/cryptography-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..c8cd8f4a594c
--- /dev/null
+++ b/dev-python/cryptography/cryptography-1.0.2-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# only works with >=pypy-2.6
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Library providing cryptographic recipes and primitives"
+HOMEPAGE="https://github.com/pyca/cryptography/ https://pypi.python.org/pypi/cryptography/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="libressl test"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ $(python_gen_cond_dep '>=dev-python/cffi-1.1.0:=[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 python3_3 pypy)
+ >=dev-python/idna-2.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/ipaddress[${PYTHON_USEDEP}]' python2_7 pypy)
+ >=dev-python/pyasn1-0.1.8[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=virtual/pypy-2.6.0' pypy )
+ "
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ~dev-python/cryptography-vectors-${PV}[${PYTHON_USEDEP}]
+ dev-python/iso8601[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.4.2[${PYTHON_USEDEP}]
+ <dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( AUTHORS.rst CONTRIBUTING.rst README.rst )
+
+python_test() {
+ py.test -v -v -x || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/cryptography/cryptography-1.0.2.ebuild b/dev-python/cryptography/cryptography-1.0.2.ebuild
index d4483e107054..e7979826cb92 100644
--- a/dev-python/cryptography/cryptography-1.0.2.ebuild
+++ b/dev-python/cryptography/cryptography-1.0.2.ebuild
@@ -5,7 +5,7 @@
EAPI=5
# only works with >=pypy-2.6
-PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
inherit distutils-r1