summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-28 08:34:54 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-28 09:28:34 +0100
commitc3a1e59d0d88859586b8179d8d4e7a6a25bc806b (patch)
treef960d3430d2e6235f36bead4c2f69aa2cff2a0b7 /dev-python/cssselect2/cssselect2-0.5.0.ebuild
parentdev-python/weasyprint: Bump to 54.2 (diff)
downloadgentoo-c3a1e59d0d88859586b8179d8d4e7a6a25bc806b.tar.gz
gentoo-c3a1e59d0d88859586b8179d8d4e7a6a25bc806b.tar.bz2
gentoo-c3a1e59d0d88859586b8179d8d4e7a6a25bc806b.zip
dev-python/cssselect2: Bump to 0.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cssselect2/cssselect2-0.5.0.ebuild')
-rw-r--r--dev-python/cssselect2/cssselect2-0.5.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/cssselect2/cssselect2-0.5.0.ebuild b/dev-python/cssselect2/cssselect2-0.5.0.ebuild
new file mode 100644
index 000000000000..4468a25aae64
--- /dev/null
+++ b/dev-python/cssselect2/cssselect2-0.5.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Parses CSS3 Selectors and translates them to XPath 1.0"
+HOMEPAGE="
+ https://cssselect2.readthedocs.io/en/latest/
+ https://pypi.org/project/cssselect2/
+ https://github.com/Kozea/cssselect2/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/tinycss2[${PYTHON_USEDEP}]
+ dev-python/webencodings[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/addopts/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}