summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-23 08:35:07 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-23 09:12:18 +0100
commit9e173ca60adcf84e73f3bf5077dab327c5415964 (patch)
tree422af0ca011f8180558b784fece7be2a8160fb51 /dev-python/cssutils
parentdev-python/github3: Add explicit cryptography dep (diff)
downloadgentoo-9e173ca60adcf84e73f3bf5077dab327c5415964.tar.gz
gentoo-9e173ca60adcf84e73f3bf5077dab327c5415964.tar.bz2
gentoo-9e173ca60adcf84e73f3bf5077dab327c5415964.zip
dev-python/cssutils: Bump to 2.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cssutils')
-rw-r--r--dev-python/cssutils/Manifest1
-rw-r--r--dev-python/cssutils/cssutils-2.4.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/cssutils/Manifest b/dev-python/cssutils/Manifest
index eef8e73e8005..8c06275cb14e 100644
--- a/dev-python/cssutils/Manifest
+++ b/dev-python/cssutils/Manifest
@@ -1 +1,2 @@
DIST cssutils-2.3.0.tar.gz 725849 BLAKE2B 7c6f0280c24eb9cf8c6e4215fc6a102ea0b1f72f52b06d8396601a19ffe457fa628bbf5b9f6c020185378ddf26c96e4aec11026e686343513db9141c7ca22dfd SHA512 9919224a61222e860a99ec80e6375a472b89c52af72272c1de7bcd5fd31cf8570a04da7762c62a17a85bef2c41b1c67447583087df4c86c1f8969ad4875a76d2
+DIST cssutils-2.4.0.tar.gz 725986 BLAKE2B 2f8d0166288e3af1f838fec3443293b4166bab6e2e115e198f3e6f7a0ec0949262de77eaeebe7437b3cf27567780f988884ce1225b94c379cabddcae0fe10543 SHA512 53e18f9d06905dbda5382a3ed6ef1808571e8a32204864364b0a344e641c774f0998bf23ad0997b34ddbe9f04d3d2c7d622249cfeb0a9e846f7fb1530ae9b12b
diff --git a/dev-python/cssutils/cssutils-2.4.0.ebuild b/dev-python/cssutils/cssutils-2.4.0.ebuild
new file mode 100644
index 000000000000..cb65c2fe41ca
--- /dev/null
+++ b/dev-python/cssutils/cssutils-2.4.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A CSS Cascading Style Sheets library"
+HOMEPAGE="https://pypi.org/project/cssutils/ https://cthedot.de/cssutils/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_resources[${PYTHON_USEDEP}]
+ ' 3.8)
+ )"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # network
+ encutils/__init__.py::encutils
+ cssutils/tests/test_parse.py::CSSParserTestCase::test_parseUrl
+ examples/website.py::website.logging
+)