summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-10-12 17:56:10 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-16 20:21:06 +0200
commit46c4e06d91249983f45355804734647f7111e382 (patch)
tree808d7aeae1fc6c914ff79af695d1465e432398ab /dev-python/ctypescrypto/ctypescrypto-0.5.ebuild
parentdev-python/crcmod: correct DISTUTILS_USE_SETUPTOOLS (diff)
downloadgentoo-46c4e06d91249983f45355804734647f7111e382.tar.gz
gentoo-46c4e06d91249983f45355804734647f7111e382.tar.bz2
gentoo-46c4e06d91249983f45355804734647f7111e382.zip
dev-python/ctypescrypto: correct DISTUTILS_USE_SETUPTOOLS
Closes: https://bugs.gentoo.org/748072 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ctypescrypto/ctypescrypto-0.5.ebuild')
-rw-r--r--dev-python/ctypescrypto/ctypescrypto-0.5.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-python/ctypescrypto/ctypescrypto-0.5.ebuild b/dev-python/ctypescrypto/ctypescrypto-0.5.ebuild
index c6686d39c74e..26427d4300ee 100644
--- a/dev-python/ctypescrypto/ctypescrypto-0.5.ebuild
+++ b/dev-python/ctypescrypto/ctypescrypto-0.5.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+DISTUTILS_USE_SETUPTOOLS=no
PYTHON_COMPAT=( python3_{6..7} )
inherit distutils-r1
@@ -24,7 +25,6 @@ RESTRICT="!test? ( test )"
REQUIRED_USE="test? ( gost )"
RDEPEND="gost? ( dev-libs/gost-engine:= )"
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
python_prepare_all() {
# Remove failed tests