summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-24 20:23:43 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-24 20:48:34 +0100
commit81b6fe8978dcb2e345083030a2deb655cb1692f0 (patch)
tree18e7114265445632374f4e28ffe9c20d4b694df2 /dev-python/cwcwidth
parentxfce-extra/xfce4-whiskermenu-plugin: Bump to 2.5.3 (diff)
downloadgentoo-81b6fe8978dcb2e345083030a2deb655cb1692f0.tar.gz
gentoo-81b6fe8978dcb2e345083030a2deb655cb1692f0.tar.bz2
gentoo-81b6fe8978dcb2e345083030a2deb655cb1692f0.zip
dev-python/cwcwidth: New package (Cython version of wcwidth)
Add the Cython alternative to dev-python/wcwidth, that uses the libc functions. It is a new dependency of dev-python/curtsies. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cwcwidth')
-rw-r--r--dev-python/cwcwidth/Manifest1
-rw-r--r--dev-python/cwcwidth/cwcwidth-0.1.1.ebuild29
-rw-r--r--dev-python/cwcwidth/metadata.xml11
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/cwcwidth/Manifest b/dev-python/cwcwidth/Manifest
new file mode 100644
index 000000000000..62c9509edadf
--- /dev/null
+++ b/dev-python/cwcwidth/Manifest
@@ -0,0 +1 @@
+DIST cwcwidth-0.1.1.gh.tar.gz 9054 BLAKE2B fb907d467a143851cc000061f9787f032788d7b684307341208ed498ade160bcd01d372ee2281fde7d1e1561aaa309d6d0bf9b776abaaef042f8b22e9df8d948 SHA512 b025af3a21d22634fe154f32fdbf380eb56d085e247147b2d0031ca36ef9d8de68aaae8133e611ec3bb36e2bc69f384e3dc23654abde2cb8b715305ba26cb66d
diff --git a/dev-python/cwcwidth/cwcwidth-0.1.1.ebuild b/dev-python/cwcwidth/cwcwidth-0.1.1.ebuild
new file mode 100644
index 000000000000..fc41a3538ac6
--- /dev/null
+++ b/dev-python/cwcwidth/cwcwidth-0.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for wc(s)width"
+HOMEPAGE="
+ https://github.com/sebastinas/cwcwidth/
+ https://pypi.org/project/cwcwidth/"
+SRC_URI="
+ https://github.com/sebastinas/cwcwidth/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+src_test() {
+ cd tests || die
+ distutils-r1_src_test
+}
diff --git a/dev-python/cwcwidth/metadata.xml b/dev-python/cwcwidth/metadata.xml
new file mode 100644
index 000000000000..9a01d15c55f6
--- /dev/null
+++ b/dev-python/cwcwidth/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">sebastinas/cwcwidth</remote-id>
+ <remote-id type="pypi">cwcwidth</remote-id>
+ </upstream>
+</pkgmetadata>