summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-25 20:57:47 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-25 21:01:48 +0300
commite4f56d7ae3e3f16abdb42a50d288386bc5f4101c (patch)
treec5c0e52dc02370f95fe9d5e6c5c846dea0a33e85 /dev-python/cwcwidth
parentdev-python/coreschema: enable py3.11 (diff)
downloadgentoo-e4f56d7ae3e3f16abdb42a50d288386bc5f4101c.tar.gz
gentoo-e4f56d7ae3e3f16abdb42a50d288386bc5f4101c.tar.bz2
gentoo-e4f56d7ae3e3f16abdb42a50d288386bc5f4101c.zip
dev-python/cwcwidth: Use PEP517 build
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/cwcwidth')
-rw-r--r--dev-python/cwcwidth/cwcwidth-0.1.6-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/cwcwidth/cwcwidth-0.1.6-r1.ebuild b/dev-python/cwcwidth/cwcwidth-0.1.6-r1.ebuild
new file mode 100644
index 000000000000..4cb7b7736243
--- /dev/null
+++ b/dev-python/cwcwidth/cwcwidth-0.1.6-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for wc(s)width"
+HOMEPAGE="
+ https://github.com/sebastinas/cwcwidth/
+ https://pypi.org/project/cwcwidth/"
+SRC_URI="
+ https://github.com/sebastinas/cwcwidth/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+src_test() {
+ cd tests || die
+ distutils-r1_src_test
+}