summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-16 11:19:13 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-16 11:19:20 +0100
commite2b69b9548199d875b3fbac101f5b6dbaf34c031 (patch)
treeed25147c16960a1aaf6265a7250e765448cfb7e4 /dev-python/cycler/cycler-0.10.0.ebuild
parentdev-python/sqlalchemy: Version Bump (diff)
downloadgentoo-e2b69b9548199d875b3fbac101f5b6dbaf34c031.tar.gz
gentoo-e2b69b9548199d875b3fbac101f5b6dbaf34c031.tar.bz2
gentoo-e2b69b9548199d875b3fbac101f5b6dbaf34c031.zip
dev-python/cycler: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/cycler/cycler-0.10.0.ebuild')
-rw-r--r--dev-python/cycler/cycler-0.10.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/cycler/cycler-0.10.0.ebuild b/dev-python/cycler/cycler-0.10.0.ebuild
new file mode 100644
index 000000000000..0e19cb15e404
--- /dev/null
+++ b/dev-python/cycler/cycler-0.10.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+MY_PN="Cycler"
+
+DESCRIPTION="Composable style cycles"
+HOMEPAGE="
+ http://matplotlib.org/cycler/
+ https://pypi.python.org/pypi/Cycler/
+ http://github.com/matplotlib/cycler"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+# Not shipped
+# https://github.com/matplotlib/cycler/issues/21
+RESTRICT=test
+
+python_test() {
+ nosetests --verbosity=3 || die
+}