summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-11 08:54:09 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-11 10:01:40 +0200
commit2e988f10b81919d6ae575a04165692932ec9c5b9 (patch)
tree35e507f088b13d48e718223cfaf778e5d8e2f18a /dev-python/cython
parentdev-python/cliff: Bump to 3.2.0 (diff)
downloadgentoo-2e988f10b81919d6ae575a04165692932ec9c5b9.tar.gz
gentoo-2e988f10b81919d6ae575a04165692932ec9c5b9.tar.bz2
gentoo-2e988f10b81919d6ae575a04165692932ec9c5b9.zip
dev-python/cython: Bump to 0.29.20
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cython')
-rw-r--r--dev-python/cython/Manifest1
-rw-r--r--dev-python/cython/cython-0.29.20.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/dev-python/cython/Manifest b/dev-python/cython/Manifest
index 9a6a6c286907..d4a04a90b5e0 100644
--- a/dev-python/cython/Manifest
+++ b/dev-python/cython/Manifest
@@ -2,3 +2,4 @@ DIST cython-0.29.15.gh.tar.gz 2075879 BLAKE2B e6322656c819c6b09e235c32d2b520e8fe
DIST cython-0.29.17.gh.tar.gz 2080768 BLAKE2B f53f8593f4ab9ef87c8fff47a031d365a748b617b7ee41872768a6a649ca3c6a6f9a338f115881117cbb4ffe1811047ac5fdcac745d6387eee29487c9da4c297 SHA512 f722e4feb0fcd0de7b882d0ba7cd78c37b6aaa4438619607665ea269b207a482fab6ca65cf12bab54d94b5929776c973a270c0748ed35b0f88a72811bf90d4df
DIST cython-0.29.18.gh.tar.gz 2083532 BLAKE2B 7e10a32f15542ed0d7d381223f6f20ec75d7ec39979ca58192cc0f95407cece31fb053776072b49e447ffb0ab5ad1918c6b53ad8cb277df08fabe0eab8ccf958 SHA512 5a1430345fbe42235a58fd44dd4e4ce17c68485349295af6c4e9a01a06117e18ee7700c34fb5974759f012acd5cf8400ed014ef16397539272c38881e905234a
DIST cython-0.29.19.gh.tar.gz 2083634 BLAKE2B 47ed2c8b8c4d56889f4414b974edac878a454c2cefff77bb3ac5cb51f926c19e3466949e0c9f470d896589e881afa32d8873c71d54b3999d221ae94f2b2d4588 SHA512 402f95f82099db0ae99ca2f849a9aef97558c9c6be62d3b3c66c346ecc94efbbe824ffc77f3cc6dd1d7054a2fb0332b10fe855ca1b054095f2df2ee297fd96a7
+DIST cython-0.29.20.gh.tar.gz 2087315 BLAKE2B c429dd2aec6c6dec0a3430ad8aefd17b62b65d9e2e7be0d48e0ebb808897533ac724ba69bdd639e3cdab2da2399f7dccea524dd71a48594e44c7a737026a5b5a SHA512 5bd0506abf8e0a823316e697db021e1e12296fecef2165ea4b84fa595554ebcdcf2688cb675c77e0e1567ab44ed502757b5eb4ea55b84505ae350f70e4d90ecc
diff --git a/dev-python/cython/cython-0.29.20.ebuild b/dev-python/cython/cython-0.29.20.ebuild
new file mode 100644
index 000000000000..8b4b6e7acc61
--- /dev/null
+++ b/dev-python/cython/cython-0.29.20.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 toolchain-funcs elisp-common
+
+DESCRIPTION="A Python to C compiler"
+HOMEPAGE="https://cython.org https://pypi.org/project/Cython/
+ https://github.com/cython/cython"
+SRC_URI="https://github.com/cython/cython/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="emacs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ emacs? ( >=app-editors/emacs-23.1:* )
+"
+BDEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' \
+ python3_{6,7,8})
+ )"
+
+PATCHES=(
+ "${FILESDIR}/cython-0.29.14-sphinx-update.patch"
+)
+
+SITEFILE=50cython-gentoo.el
+
+distutils_enable_sphinx docs
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ local CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
+ fi
+
+ # Python gets confused when it is in sys.path before build.
+ local -x PYTHONPATH=
+
+ distutils-r1_python_compile
+}
+
+python_compile_all() {
+ use emacs && elisp-compile Tools/cython-mode.el
+}
+
+python_test() {
+ if [[ ${EPYTHON} == python3.9 ]]; then
+ # https://github.com/cython/cython/issues/3349
+ einfo "Skipping py3.9 due to known failures"
+ return
+ fi
+
+ tc-export CC
+ # https://github.com/cython/cython/issues/1911
+ local -x CFLAGS="${CFLAGS} -fno-strict-overflow"
+ "${PYTHON}" runtests.py -vv --work-dir "${BUILD_DIR}"/tests \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( CHANGES.rst README.rst ToDo.txt USAGE.txt )
+ distutils-r1_python_install_all
+
+ if use emacs; then
+ elisp-install ${PN} Tools/cython-mode.*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}