summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-22 00:47:11 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-22 00:50:21 +0200
commitab072ac02c0e86973eb1fd4a1b078c895b969270 (patch)
treeedaa38f559a1245d59cfbc9778cecf4d0a03fc7f /dev-python/cython
parentdev-python/coloredlogs: Remove old (diff)
downloadgentoo-ab072ac02c0e86973eb1fd4a1b078c895b969270.tar.gz
gentoo-ab072ac02c0e86973eb1fd4a1b078c895b969270.tar.bz2
gentoo-ab072ac02c0e86973eb1fd4a1b078c895b969270.zip
dev-python/cython: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cython')
-rw-r--r--dev-python/cython/Manifest1
-rw-r--r--dev-python/cython/cython-0.29.20-r2.ebuild81
-rw-r--r--dev-python/cython/files/cython-0.29.20-py39-classmeth.patch34
3 files changed, 0 insertions, 116 deletions
diff --git a/dev-python/cython/Manifest b/dev-python/cython/Manifest
index 50b7782d5f01..52ea40b8df0a 100644
--- a/dev-python/cython/Manifest
+++ b/dev-python/cython/Manifest
@@ -1,3 +1,2 @@
DIST cython-0.29.15.gh.tar.gz 2075879 BLAKE2B e6322656c819c6b09e235c32d2b520e8fe917c864047d028dd67041e70251025f14accbd76499b7b9290d0424989adf89321f251526e66a892bdc243ba80ba7f SHA512 bd0872359d31a41750353bb0d7f03c2a40aa2bf6e492148e693321cef15b02ae4f8d5f5a00efde7216f09a6ac06f2bb3ded9d00e27ad0cfc53605f3a9ef55af8
-DIST cython-0.29.20.gh.tar.gz 2087315 BLAKE2B c429dd2aec6c6dec0a3430ad8aefd17b62b65d9e2e7be0d48e0ebb808897533ac724ba69bdd639e3cdab2da2399f7dccea524dd71a48594e44c7a737026a5b5a SHA512 5bd0506abf8e0a823316e697db021e1e12296fecef2165ea4b84fa595554ebcdcf2688cb675c77e0e1567ab44ed502757b5eb4ea55b84505ae350f70e4d90ecc
DIST cython-0.29.21.gh.tar.gz 2088511 BLAKE2B 7a4ddabb65a519d3c71454ac8417438a3a9c46b47489c18e7c7e82ffcb5d5f2f0c5246d0b364f8317d374c53f0c83844c73c7d2ef6b9f75f10707aaf2931ce41 SHA512 2c0c3e3fff07106eb98862f71cd5dec9ff29460cf9b9e4de74537ca5e033f7523989beb5fbdc14723beaf94a535976f75c803e791b87e017961d9694b8c37679
diff --git a/dev-python/cython/cython-0.29.20-r2.ebuild b/dev-python/cython/cython-0.29.20-r2.ebuild
deleted file mode 100644
index a204104cd163..000000000000
--- a/dev-python/cython/cython-0.29.20-r2.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 toolchain-funcs elisp-common
-
-DESCRIPTION="A Python to C compiler"
-HOMEPAGE="https://cython.org https://pypi.org/project/Cython/
- https://github.com/cython/cython"
-SRC_URI="https://github.com/cython/cython/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="emacs test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- emacs? ( >=app-editors/emacs-23.1:* )
-"
-BDEPEND="${RDEPEND}
- test? (
- $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' \
- python3_{6,7,8})
- )"
-
-PATCHES=(
- "${FILESDIR}/cython-0.29.14-sphinx-update.patch"
- "${FILESDIR}"/${P}-py39-classmeth.patch
-)
-
-SITEFILE=50cython-gentoo.el
-
-distutils_enable_sphinx docs
-
-python_compile() {
- if ! python_is_python3; then
- local CFLAGS="${CFLAGS} -fno-strict-aliasing"
- local CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
- fi
-
- # Python gets confused when it is in sys.path before build.
- local -x PYTHONPATH=
-
- distutils-r1_python_compile
-}
-
-python_compile_all() {
- use emacs && elisp-compile Tools/cython-mode.el
-}
-
-python_test() {
- tc-export CC
- # https://github.com/cython/cython/issues/1911
- local -x CFLAGS="${CFLAGS} -fno-strict-overflow"
- "${PYTHON}" runtests.py -vv --work-dir "${BUILD_DIR}"/tests \
- || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- local DOCS=( CHANGES.rst README.rst ToDo.txt USAGE.txt )
- distutils-r1_python_install_all
-
- if use emacs; then
- elisp-install ${PN} Tools/cython-mode.*
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-python/cython/files/cython-0.29.20-py39-classmeth.patch b/dev-python/cython/files/cython-0.29.20-py39-classmeth.patch
deleted file mode 100644
index 914269a5a232..000000000000
--- a/dev-python/cython/files/cython-0.29.20-py39-classmeth.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From c29a7818d3b6806a457af698aec446d3d28d4f80 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Sun, 14 Jun 2020 13:45:21 +0200
-Subject: [PATCH] Always bind Cython functions in py3
-
-Rebased for cython 0.29.x, and made conditional to Python 3. This
-does not solve the original staticmethod problem in Python 2 but it does
-resolve classmethod problems in Python 3.9. Therefore, it unbreaks
-other packages on Python 3.9, improves overall state for Python 3
-and does not introduce regressions in Python 2.
----
- Cython/Utility/CythonFunction.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/Cython/Utility/CythonFunction.c b/Cython/Utility/CythonFunction.c
-index a65c8eee36..33d0a4750a 100644
---- a/Cython/Utility/CythonFunction.c
-+++ b/Cython/Utility/CythonFunction.c
-@@ -548,6 +548,7 @@ static int __Pyx_CyFunction_traverse(__pyx_CyFunctionObject *m, visitproc visit,
-
- static PyObject *__Pyx_CyFunction_descr_get(PyObject *func, PyObject *obj, PyObject *type)
- {
-+#if PY_MAJOR_VERSION < 3
- __pyx_CyFunctionObject *m = (__pyx_CyFunctionObject *) func;
-
- if (m->flags & __Pyx_CYFUNCTION_STATICMETHOD) {
-@@ -563,6 +564,7 @@ static PyObject *__Pyx_CyFunction_descr_get(PyObject *func, PyObject *obj, PyObj
-
- if (obj == Py_None)
- obj = NULL;
-+#endif
- return __Pyx_PyMethod_New(func, obj, type);
- }
-