summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-26 20:01:36 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-26 20:02:21 +0100
commitbbe06839dcad5655844f03334cc0af259f702d4e (patch)
tree1a32ac418ffe1639691f090edb7888985a9aa4e0 /dev-python/cytoolz/cytoolz-0.8.0.ebuild
parentnet-mail/tnef: drop to ~hppa (diff)
downloadgentoo-bbe06839dcad5655844f03334cc0af259f702d4e.tar.gz
gentoo-bbe06839dcad5655844f03334cc0af259f702d4e.tar.bz2
gentoo-bbe06839dcad5655844f03334cc0af259f702d4e.zip
dev-python/cytoolz: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cytoolz/cytoolz-0.8.0.ebuild')
-rw-r--r--dev-python/cytoolz/cytoolz-0.8.0.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/cytoolz/cytoolz-0.8.0.ebuild b/dev-python/cytoolz/cytoolz-0.8.0.ebuild
deleted file mode 100644
index f1eeef58cd52..000000000000
--- a/dev-python/cytoolz/cytoolz-0.8.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Cython implementation of Toolz: High performance functional utilities"
-HOMEPAGE="https://pypi.org/project/cytoolz/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# Informed by author the dep in toolz is not only required but the
-# tests are version sensitive.
-# https://github.com/pytoolz/cytoolz/issues/57
-RDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}]
- >=dev-python/toolz-0.8[${PYTHON_USEDEP}] )"
-
-python_compile() {
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
-
- distutils-r1_python_compile
-}
-
-python_test() {
- pushd "${BUILD_DIR}"/lib/ > /dev/null || die
- PYTHONPATH=.:${PN} nosetests --with-doctest ${PN} || die "tests failed under ${EPYTHON}"
- popd > /dev/null || die
-}