summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/cytoolz
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/cytoolz')
-rw-r--r--dev-python/cytoolz/Manifest3
-rw-r--r--dev-python/cytoolz/cytoolz-0.7.1.ebuild26
-rw-r--r--dev-python/cytoolz/cytoolz-0.7.2-r2.ebuild38
-rw-r--r--dev-python/cytoolz/cytoolz-0.7.3.ebuild38
-rw-r--r--dev-python/cytoolz/metadata.xml8
5 files changed, 113 insertions, 0 deletions
diff --git a/dev-python/cytoolz/Manifest b/dev-python/cytoolz/Manifest
new file mode 100644
index 000000000000..f2c258d24f7a
--- /dev/null
+++ b/dev-python/cytoolz/Manifest
@@ -0,0 +1,3 @@
+DIST cytoolz-0.7.1.tar.gz 250988 SHA256 297b3cf8606afc3332e0d0b0da707b306f8cec6f8f9a962a04181caee9bbf27e SHA512 742acde6316d5fe0cda1cb7be86812ad79bad9b5402e3b7d3d29f22afce3222d14fa8fe5a41d9cb2f3a3745f6a7ca5db3395873a5dee3e55c661fc01bfa3b007 WHIRLPOOL a54572e85e160fb7dda5eeb3ef2e5c4aca9c4e5a390321112783cfad1e40100d37eb0d763d92d3335a4ffab50bb562ce7f8138b9bc4a5722ddbd115f625baad1
+DIST cytoolz-0.7.2.tar.gz 281930 SHA256 0800949df710aa487f52b1a9f97d8844e81e07067d6ec95581b1b792c098c159 SHA512 3423b25687b143e5c80bafbb20c1220f3030348844dc753c25e5aebd9ce0b0d3c571b386138c9f6d6546c22cd5a3f1ff73e0c2ae6ee5ad1f7607d90cc7e2da3c WHIRLPOOL bffb53e662aac32eacb7222103f79c89b8708628508e5fd6326a2bffbc30cd2a422b554c18acb537e7803cb80d1f9e6aee4501505f905358af9b19d4adf15ec1
+DIST cytoolz-0.7.3.tar.gz 304597 SHA256 202eb77cf2405c702c2172e5c2e66e3e2611f866640c99b38f24f96ad680dea8 SHA512 a9e83cb22b3b9af0c28754696c59a081e74e03b23f63eaf7bf31526d33b9d645bb82ec98e650e1a6c17d367951cbea6417c6b8c69ff3d80e2d45a8a44c97ed16 WHIRLPOOL fd16958c1158be3265c22a27d8c5a12510e20038cb846dac13ce6f24060096b64030bc4aea5f0c48bff6464b8fab048c3e3b0aef604e69693b38d5c9b7056051
diff --git a/dev-python/cytoolz/cytoolz-0.7.1.ebuild b/dev-python/cytoolz/cytoolz-0.7.1.ebuild
new file mode 100644
index 000000000000..bbd81d984d26
--- /dev/null
+++ b/dev-python/cytoolz/cytoolz-0.7.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Cython implementation of Toolz: High performance functional utilities"
+HOMEPAGE="https://pypi.python.org/pypi/cytoolz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+
+ distutils-r1_python_compile
+}
diff --git a/dev-python/cytoolz/cytoolz-0.7.2-r2.ebuild b/dev-python/cytoolz/cytoolz-0.7.2-r2.ebuild
new file mode 100644
index 000000000000..eaa2e9af3bff
--- /dev/null
+++ b/dev-python/cytoolz/cytoolz-0.7.2-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Cython implementation of Toolz: High performance functional utilities"
+HOMEPAGE="https://pypi.python.org/pypi/cytoolz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# Informed by author the dep in toolz is not only required but the
+# tests are version sensitive.
+# https://github.com/pytoolz/cytoolz/issues/57
+RDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.7.1[${PYTHON_USEDEP}] )"
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ pushd "${BUILD_DIR}"/lib/ > /dev/null
+ PYTHONPATH=.:${PN} nosetests --with-doctest ${PN} || die "tests failed under ${EPYTHON}"
+ popd > /dev/null
+}
diff --git a/dev-python/cytoolz/cytoolz-0.7.3.ebuild b/dev-python/cytoolz/cytoolz-0.7.3.ebuild
new file mode 100644
index 000000000000..eaa2e9af3bff
--- /dev/null
+++ b/dev-python/cytoolz/cytoolz-0.7.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Cython implementation of Toolz: High performance functional utilities"
+HOMEPAGE="https://pypi.python.org/pypi/cytoolz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# Informed by author the dep in toolz is not only required but the
+# tests are version sensitive.
+# https://github.com/pytoolz/cytoolz/issues/57
+RDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.7.1[${PYTHON_USEDEP}] )"
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ pushd "${BUILD_DIR}"/lib/ > /dev/null
+ PYTHONPATH=.:${PN} nosetests --with-doctest ${PN} || die "tests failed under ${EPYTHON}"
+ popd > /dev/null
+}
diff --git a/dev-python/cytoolz/metadata.xml b/dev-python/cytoolz/metadata.xml
new file mode 100644
index 000000000000..99e0558beda5
--- /dev/null
+++ b/dev-python/cytoolz/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">cytoolz</remote-id>
+ </upstream>
+</pkgmetadata>