summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-23 09:46:33 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-23 11:28:43 +0200
commit2ea27722feb8b890d1202e11441bfc1ef13b6121 (patch)
tree390e681c5c9e18c103a06bcc6c56ab53a3110f36 /dev-python/dask
parentdev-python/google-api-python-client: Bump to 2.10.0 (diff)
downloadgentoo-2ea27722feb8b890d1202e11441bfc1ef13b6121.tar.gz
gentoo-2ea27722feb8b890d1202e11441bfc1ef13b6121.tar.bz2
gentoo-2ea27722feb8b890d1202e11441bfc1ef13b6121.zip
dev-python/dask: Bump to 2021.6.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dask')
-rw-r--r--dev-python/dask/Manifest1
-rw-r--r--dev-python/dask/dask-2021.6.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index c6854c8a8148..f3e4e8c778e9 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -1,3 +1,4 @@
DIST dask-2021.5.0.tar.gz 3710206 BLAKE2B d02bd280a704cf03fb403c58567be33c414171ef3ee1eed2f788cf2b3026c2aa3806c19a8e9f239c93a0eb8ab2474f14fa80b8e1057ae0db1c0ce4a68f0cedad SHA512 bfc2c870df02f1879907621cb9abdce8bf03d07fea2823acea68b220ed414ee146036b73eb50c92608140ed18566e7a53807dcc1fdf534876920467979908592
DIST dask-2021.6.0.tar.gz 3717136 BLAKE2B bc524dc4e885588ea92c0b24b6abe917b6a3989f7faa21d4dffa490f2952f4f7e90ce55e28ed97b34e44bf2c41a753fe80f092559999fa42e450b289c4b89933 SHA512 a4a1e86c286e0796f7ed79dd10c5c0f80e40bb246a7c25d45aed5e73a2d6c1da8743bf6b61ca784a8412403aa6e62007c937bbbdd8ffccf7170443454ff5601d
DIST dask-2021.6.1.tar.gz 3725331 BLAKE2B 7b466507b968dafd2c6f3a3db70c3f557ed877bd489067ff5243794c44a9e77f9b72b4a000eb0865d2096845b3c6005739214bed1215ae053d9d1c313c6bb52c SHA512 c3c032ae8d67994cb924e23787a571ad75ac88ee682542aa486dd76b38ba25c809593e9bb11a716589eeea437aaf8b69a4ecdf676c417fe566d92a2b1a8678b6
+DIST dask-2021.6.2.tar.gz 3725731 BLAKE2B 957cf70c328462c87eb52bb2fe3d471705ab6bbc233badb8d5ba93ade4b7caa05e47399f26f37b69213df16e76fdf8f042a082a0d2d96797bca836311349a6b3 SHA512 2949a0a028d08794936faaeeea3b36c97ac1492288519efa0fd1e6bbb9b5b52b730657b8b342a47ca0183d98e9179836423847670fc12c14be0890daa4b773b4
diff --git a/dev-python/dask/dask-2021.6.2.ebuild b/dev-python/dask/dask-2021.6.2.ebuild
new file mode 100644
index 000000000000..d3f5be8aad05
--- /dev/null
+++ b/dev-python/dask/dask-2021.6.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="https://dask.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/cloudpickle-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.15.1[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.25.0[${PYTHON_USEDEP}]
+ >=dev-python/partd-0.3.10[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.8.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/toolz[${PYTHON_USEDEP}]
+ test? (
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-1.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p no:flaky -m "not network"
+}