summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-14 07:45:54 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-14 10:03:15 +0200
commit5893517746e5d025cc193055475d3998f8717462 (patch)
tree1a413814edd40cbc55802cf263b38c7d20d30925 /dev-python/dask
parentx11-drivers/nvidia-drivers: stabilize 470.57.02 for amd64 (diff)
downloadgentoo-5893517746e5d025cc193055475d3998f8717462.tar.gz
gentoo-5893517746e5d025cc193055475d3998f8717462.tar.bz2
gentoo-5893517746e5d025cc193055475d3998f8717462.zip
dev-python/dask: Bump to 2021.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dask')
-rw-r--r--dev-python/dask/Manifest1
-rw-r--r--dev-python/dask/dask-2021.8.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index e02eca46bef4..f9170743c8dc 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -2,3 +2,4 @@ DIST dask-2021.6.2.tar.gz 3725731 BLAKE2B 957cf70c328462c87eb52bb2fe3d471705ab6b
DIST dask-2021.7.0.tar.gz 3730549 BLAKE2B 8f76648614adbef8ca1feb01f5b39d4ad217eb5178c4b7ace72d3764062b172d83b74e9fad5eeff0a745025e0cb2bf47bdb14beb03b1520130332ece00c3e318 SHA512 3dbeefe08af6536f19a03ead69372dfa7a26eff66d768fa8e238341822136a2314fca0291694ad22bdfe3618a4ed6785d836ceb5cc4231f361d97f0cbba0edbf
DIST dask-2021.7.1.tar.gz 3734645 BLAKE2B 4dfd98c72a54712dc4bee97305811bf411bceb5e5ad60d6a82e94b785be51ea8e2ea6ae853b85f45a9765f0220f4c35b526582f1587932178d53884df1d697d7 SHA512 0b5ab5e08503468ca26ee2b0e195979055c9fa439e62f1c47e73521856f7ddb2fa608457cd1e4a0edcd3162254d404ae4995319b73b142bf6bd804c6b63b3f22
DIST dask-2021.7.2.tar.gz 3739041 BLAKE2B e32389a5d6a47a9c0f741a33d2f9aeb8887c951d4a53ad7e2bdc5d7007e2e7b8db9b639b95725bb70cfdf1f3568aa2541c7f46c5c87cbb50b5433866b7f0e870 SHA512 029832ea2db342cc63dcfc4e5a563e6e92f5d26298ca19d7815548acceb8098e94b53acb5df1a6923172e7014b6235ddb34921f2855701921556db83a9411afa
+DIST dask-2021.8.0.tar.gz 3742254 BLAKE2B a4f086181dc5dd36561d365ac929c0399d05fbb9d39e025ad06a609477cd4e257abb93760244032285812409c413a110f213ad2918ec1042e1526f847da1056f SHA512 b205c05965aec419650b9125193d96383ad9ffa96e8aef92ac15da339e0ba9d1c40ba6bc176e56aca0ef6f84d7a523d7157aba90e146317aef58fe34dc07e2bc
diff --git a/dev-python/dask/dask-2021.8.0.ebuild b/dev-python/dask/dask-2021.8.0.ebuild
new file mode 100644
index 000000000000..a7f474643d23
--- /dev/null
+++ b/dev-python/dask/dask-2021.8.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="https://dask.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/cloudpickle-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.15.1[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.25.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ >=dev-python/partd-0.3.10[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.8.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/toolz[${PYTHON_USEDEP}]
+ test? (
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # require old sqlalchemy
+ dask/dataframe/io/tests/test_sql.py
+ )
+
+ epytest -p no:flaky -m "not network" ${deselect[@]/#/--deselect }
+}