summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-21 09:08:00 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-21 09:55:59 +0200
commit759ebe1db5b187e48cd19f923496f22eedec5cd0 (patch)
treeb1ca60f84922d3b24b640fd0a795f4396d325a5c /dev-python/dask
parentdev-python/botocore: Bump to 1.21.26 (diff)
downloadgentoo-759ebe1db5b187e48cd19f923496f22eedec5cd0.tar.gz
gentoo-759ebe1db5b187e48cd19f923496f22eedec5cd0.tar.bz2
gentoo-759ebe1db5b187e48cd19f923496f22eedec5cd0.zip
dev-python/dask: Bump to 2021.8.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dask')
-rw-r--r--dev-python/dask/Manifest1
-rw-r--r--dev-python/dask/dask-2021.8.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index c81af47fe058..acf111d0e35f 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -1,2 +1,3 @@
DIST dask-2021.7.2.tar.gz 3739041 BLAKE2B e32389a5d6a47a9c0f741a33d2f9aeb8887c951d4a53ad7e2bdc5d7007e2e7b8db9b639b95725bb70cfdf1f3568aa2541c7f46c5c87cbb50b5433866b7f0e870 SHA512 029832ea2db342cc63dcfc4e5a563e6e92f5d26298ca19d7815548acceb8098e94b53acb5df1a6923172e7014b6235ddb34921f2855701921556db83a9411afa
DIST dask-2021.8.0.tar.gz 3742254 BLAKE2B a4f086181dc5dd36561d365ac929c0399d05fbb9d39e025ad06a609477cd4e257abb93760244032285812409c413a110f213ad2918ec1042e1526f847da1056f SHA512 b205c05965aec419650b9125193d96383ad9ffa96e8aef92ac15da339e0ba9d1c40ba6bc176e56aca0ef6f84d7a523d7157aba90e146317aef58fe34dc07e2bc
+DIST dask-2021.8.1.tar.gz 3786161 BLAKE2B cb47b900e4769113e28e1cea70cb65008debb25431c05792666ca1d9aef9143061d1b0c2ce825ff1a22312c4cc615a2878591fc93236521811c19a35e70446b1 SHA512 aff7b92b66ab5d8858eb28d416c3661e64400a8ddcc9135b74b1bf3cad195a4fc55a00365c5602cb0b66ef8506e73c0f6bd2d3972ce8744d2e77095cdf040d11
diff --git a/dev-python/dask/dask-2021.8.1.ebuild b/dev-python/dask/dask-2021.8.1.ebuild
new file mode 100644
index 000000000000..a7f474643d23
--- /dev/null
+++ b/dev-python/dask/dask-2021.8.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="https://dask.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/cloudpickle-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.15.1[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.25.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ >=dev-python/partd-0.3.10[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.8.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/toolz[${PYTHON_USEDEP}]
+ test? (
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # require old sqlalchemy
+ dask/dataframe/io/tests/test_sql.py
+ )
+
+ epytest -p no:flaky -m "not network" ${deselect[@]/#/--deselect }
+}