summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-16 09:29:31 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-16 10:52:54 +0100
commitacd306672b3f5b3298b68940fb7577071a1928eb (patch)
treeb6e465e737b53653392c7e4e4fcfbfc554ec7eea /dev-python/dask
parentdev-python/ubelt: Bump to 0.9.4 (diff)
downloadgentoo-acd306672b3f5b3298b68940fb7577071a1928eb.tar.gz
gentoo-acd306672b3f5b3298b68940fb7577071a1928eb.tar.bz2
gentoo-acd306672b3f5b3298b68940fb7577071a1928eb.zip
dev-python/dask: Bump to 2021.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dask')
-rw-r--r--dev-python/dask/Manifest1
-rw-r--r--dev-python/dask/dask-2021.1.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index b9fedc023188..8fe900353a79 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -1 +1,2 @@
DIST dask-2.30.0.tar.gz 2858866 BLAKE2B ea5e1e50f9bef2ca81765ee1228ea661ea01355f4c2a495e916388cb757dc089c519eb83372abc2ece16c8ec27e3b7f7fe56a302eddfdc6c0e79247db9c1b65e SHA512 d410fcfc7e30f510bc42e9547bac912609420919489e161408d436fb26c3998eba6bfc9e4845d90b3e8589ecc317ee4bf141e2740108840f2e5a420eb20655ef
+DIST dask-2021.1.0.tar.gz 3634608 BLAKE2B 1fb74ade53ad919496c3a33452eab70492704e73c9a172d5e1451217d5a3931acad3dc48587945807bbf5096bf6674e54d3bb7d1aa3d903ee47c1c203595fa1d SHA512 a65423fa401859bb7ecd569a6a593d2fa7a7be33b4804a95b8c57e90e1be9bf2f7610a3b1b55bf760e0f618c30193cdd5a28aea3710fb69c0947b7f3793051aa
diff --git a/dev-python/dask/dask-2021.1.0.ebuild b/dev-python/dask/dask-2021.1.0.ebuild
new file mode 100644
index 000000000000..1efefeaf4884
--- /dev/null
+++ b/dev-python/dask/dask-2021.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="https://dask.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/cloudpickle-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.15.1[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.25.0[${PYTHON_USEDEP}]
+ >=dev-python/partd-0.3.10[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.8.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/toolz[${PYTHON_USEDEP}]
+ test? (
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ pytest -vv -m "not network" ||
+ die "Tests failed with ${EPYTHON}"
+}