summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-23 08:07:50 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-23 10:44:04 +0200
commitc8b5bfe70332a98ed8b3b9a55313c99c7a9e3c74 (patch)
treec520ad44fbe155809878a3f62a4acaf92ac3aedd /dev-python/dask
parentdev-python/pip: Bump to 21.3.1 (diff)
downloadgentoo-c8b5bfe70332a98ed8b3b9a55313c99c7a9e3c74.tar.gz
gentoo-c8b5bfe70332a98ed8b3b9a55313c99c7a9e3c74.tar.bz2
gentoo-c8b5bfe70332a98ed8b3b9a55313c99c7a9e3c74.zip
dev-python/dask: Bump to 2021.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dask')
-rw-r--r--dev-python/dask/Manifest1
-rw-r--r--dev-python/dask/dask-2021.10.0.ebuild46
-rw-r--r--dev-python/dask/files/dask-2021.10.0-warning.patch38
3 files changed, 85 insertions, 0 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index 4f34249beb05..29009d8b6165 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -1 +1,2 @@
+DIST dask-2021.10.0.tar.gz 3963245 BLAKE2B cfccf683a6fc3b55f2be3e62b04e733586401ab642ed2ed0a6cc6956e4179d5692fb1aa94757fceacf1b40efd7ea46b6d5f7bb5df407d0f51d2f711c1672307e SHA512 801378c1e09eeb6825603d4de8efe711c04c1d83dbd37d44a66695c1629d74e6914670015fb231b270fa61a668120358aa5cd32d4ee99096616624e8fe0905fa
DIST dask-2021.9.1.tar.gz 3794819 BLAKE2B c3ed5050581f41c4ea82ad9d1d233205f105434e5e6dcc654ba2e999b8cf105033d58ecf045d2063dabcb701cb2af6f092ecfd8435d24e5949ed2d39b54ae19e SHA512 20beca3f68c2e21d54c941049a1f352e19fcce7b5f7ecf84abf60cfb9979551a3e83938ca5439b662d35c0b64b26d726f6fea85641e737d0060c56a2e879755e
diff --git a/dev-python/dask/dask-2021.10.0.ebuild b/dev-python/dask/dask-2021.10.0.ebuild
new file mode 100644
index 000000000000..7d45502daccd
--- /dev/null
+++ b/dev-python/dask/dask-2021.10.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="https://dask.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/cloudpickle-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.15.1[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.25.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ >=dev-python/partd-0.3.10[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.8.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/toolz[${PYTHON_USEDEP}]
+ test? (
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/dask-2021.10.0-warning.patch
+)
+
+python_test() {
+ epytest -p no:flaky -m "not network"
+}
diff --git a/dev-python/dask/files/dask-2021.10.0-warning.patch b/dev-python/dask/files/dask-2021.10.0-warning.patch
new file mode 100644
index 000000000000..87c2ab318aee
--- /dev/null
+++ b/dev-python/dask/files/dask-2021.10.0-warning.patch
@@ -0,0 +1,38 @@
+From f59293c180f846a220762701006d25655095991f Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sat, 23 Oct 2021 09:09:29 +0200
+Subject: [PATCH] Fix test_describe_empty to work without global -Werror
+
+Fix test_describe_empty to work when the test suite is run without
+global -Werror. This is e.g. desirable for packagers who don't want
+the test suite for a fixed version to suddenly start failing due to
+DeprecationWarnings in dependencies that otherwise don't break
+the package.
+
+Since the test expects either a ValueError or a RuntimeWarning, it seems
+that the easiest way to assert for that is to inject the "error" filter
+for the scope of the call.
+---
+ dask/dataframe/tests/test_dataframe.py | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/dask/dataframe/tests/test_dataframe.py b/dask/dataframe/tests/test_dataframe.py
+index 32edb488..e0d88ba8 100644
+--- a/dask/dataframe/tests/test_dataframe.py
++++ b/dask/dataframe/tests/test_dataframe.py
+@@ -570,7 +570,11 @@ def test_describe_empty():
+ )
+
+ with pytest.raises((ValueError, RuntimeWarning)):
+- ddf_len0.describe(percentiles_method="dask").compute()
++ with warnings.catch_warnings():
++ # ensure that the warning is turned into an error since this is
++ # the easiest way to assert for exception-or-warning
++ warnings.simplefilter("error")
++ ddf_len0.describe(percentiles_method="dask").compute()
+
+ with pytest.raises(ValueError):
+ ddf_nocols.describe(percentiles_method="dask").compute()
+--
+2.33.1
+