summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-24 08:25:06 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-24 11:04:12 +0200
commitda5624ee1241dea62784f146c54466c7dc27cb0d (patch)
tree0f49d271d6b03048c048e98ff07102e2dc76e805 /dev-python/dask
parentdev-python/pytools: Bump to 2021.2.5 (diff)
downloadgentoo-da5624ee1241dea62784f146c54466c7dc27cb0d.tar.gz
gentoo-da5624ee1241dea62784f146c54466c7dc27cb0d.tar.bz2
gentoo-da5624ee1241dea62784f146c54466c7dc27cb0d.zip
dev-python/dask: Bump to 2021.4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dask')
-rw-r--r--dev-python/dask/Manifest1
-rw-r--r--dev-python/dask/dask-2021.4.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index 23e2205f7e0e..06aa463cfc7d 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -1 +1,2 @@
DIST dask-2021.3.0.tar.gz 3672035 BLAKE2B 17b3e808603b8524e96273ad33b69689605707a1c187b32c8ed67f054e7f242525365956800017ad5685e0c306dcd21bcfb3dbb3f9920446f03553ceb0fdd9a8 SHA512 ba5b62dd51dad29a106a4fe38a5015f7e1d7ad11eaa21a524b7c8b7d916873b9e447d065c9009e8100662aa3b1f64718b164369f173fc84f5f085a1e369e091a
+DIST dask-2021.4.1.tar.gz 3702584 BLAKE2B d6c630349f26378c1c6d15de38c112ef330bec6422664b6e5737b7a023800f1705be163cefd79cf76c1213ca6b773ee19e2dc7e3f22eb60edc23e6fd4c153e16 SHA512 55d8d3a1a3eb76ac68eed5092075301ca88ff311f6729952928fde49f90a1b9a825dc085fb38b07a0138b87a109a5913f26d683c5fd22476539f3a8f36397c32
diff --git a/dev-python/dask/dask-2021.4.1.ebuild b/dev-python/dask/dask-2021.4.1.ebuild
new file mode 100644
index 000000000000..083343d0a237
--- /dev/null
+++ b/dev-python/dask/dask-2021.4.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="https://dask.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/cloudpickle-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.15.1[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.25.0[${PYTHON_USEDEP}]
+ >=dev-python/partd-0.3.10[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.8.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/toolz[${PYTHON_USEDEP}]
+ test? (
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p no:flaky -m "not network"
+}