summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-01-07 20:09:17 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-01-10 05:26:39 +0000
commit98389f444eb62f884fdd0f08f735ed1472246ef8 (patch)
treec9a3b5daeb0c28cf3101b4fa45ee27fc0873b18e /dev-python/datashape/datashape-0.5.4.ebuild
parentdev-python/numba: version bump (diff)
downloadgentoo-98389f444eb62f884fdd0f08f735ed1472246ef8.tar.gz
gentoo-98389f444eb62f884fdd0f08f735ed1472246ef8.tar.bz2
gentoo-98389f444eb62f884fdd0f08f735ed1472246ef8.zip
dev-python/datashape: version bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/datashape/datashape-0.5.4.ebuild')
-rw-r--r--dev-python/datashape/datashape-0.5.4.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/datashape/datashape-0.5.4.ebuild b/dev-python/datashape/datashape-0.5.4.ebuild
new file mode 100644
index 000000000000..a04a3bfe5451
--- /dev/null
+++ b/dev-python/datashape/datashape-0.5.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Language defining a data description protocol"
+HOMEPAGE="https://github.com/ContinuumIO/datashape"
+SRC_URI="https://github.com/ContinuumIO/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/numpy-1.7[${PYTHON_USEDEP}]
+ >=dev-python/multipledispatch-0.4.7[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+DEPEND="
+ doc? ( ${RDEPEND} dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/'sphinx.ext.intersphinx', //" -i docs/source/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}