summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-30 22:03:42 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-30 22:26:00 +0100
commite63de3a37c303866298c846d0cf3a6b004420ea4 (patch)
treefecb2daea0edb73f220396eca114006e2866265f /dev-python/datashape
parentdev-python/colorspacious: Remove py2 (diff)
downloadgentoo-e63de3a37c303866298c846d0cf3a6b004420ea4.tar.gz
gentoo-e63de3a37c303866298c846d0cf3a6b004420ea4.tar.bz2
gentoo-e63de3a37c303866298c846d0cf3a6b004420ea4.zip
dev-python/datashape: Combine both ebuilds (remove py2)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/datashape')
-rw-r--r--dev-python/datashape/datashape-0.5.4-r1.ebuild2
-rw-r--r--dev-python/datashape/datashape-0.5.4.ebuild50
2 files changed, 1 insertions, 51 deletions
diff --git a/dev-python/datashape/datashape-0.5.4-r1.ebuild b/dev-python/datashape/datashape-0.5.4-r1.ebuild
index ba87920acb00..e72858a26c4f 100644
--- a/dev-python/datashape/datashape-0.5.4-r1.ebuild
+++ b/dev-python/datashape/datashape-0.5.4-r1.ebuild
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/blaze/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
IUSE="doc test"
RESTRICT="!test? ( test )"
diff --git a/dev-python/datashape/datashape-0.5.4.ebuild b/dev-python/datashape/datashape-0.5.4.ebuild
deleted file mode 100644
index d62fc5beed98..000000000000
--- a/dev-python/datashape/datashape-0.5.4.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Language defining a data description protocol"
-HOMEPAGE="https://github.com/blaze/datashape"
-SRC_URI="https://github.com/blaze/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/numpy-1.7[${PYTHON_USEDEP}]
- >=dev-python/multipledispatch-0.4.7[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
-"
-DEPEND="
- doc? ( ${RDEPEND} dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( ${RDEPEND}
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-python_prepare_all() {
- # Prevent un-needed d'loading
- sed -e "s/'sphinx.ext.intersphinx', //" -i docs/source/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- py.test || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-}