summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-09 00:41:13 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-09 00:41:13 +0200
commit90e30a869c57613ceeb5b64cde5e6bdae64324cb (patch)
tree3b2e43bb1d233c35dffd8bf7126368f20f7f1309 /dev-python/dbutils
parentdev-python/partd: Bump to 1.2.0 (diff)
downloadgentoo-90e30a869c57613ceeb5b64cde5e6bdae64324cb.tar.gz
gentoo-90e30a869c57613ceeb5b64cde5e6bdae64324cb.tar.bz2
gentoo-90e30a869c57613ceeb5b64cde5e6bdae64324cb.zip
dev-python/dbutils: Bump to 2.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dbutils')
-rw-r--r--dev-python/dbutils/Manifest1
-rw-r--r--dev-python/dbutils/dbutils-2.0.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/dbutils/Manifest b/dev-python/dbutils/Manifest
index cbc2610b6bbf..dff5d82afcfa 100644
--- a/dev-python/dbutils/Manifest
+++ b/dev-python/dbutils/Manifest
@@ -1,2 +1,3 @@
DIST DBUtils-1.3.tar.gz 91733 BLAKE2B 8fb3fd16208c27fbbbbcbf1e7b9de2d4d2e8008916309256bd2ae5494d0ff60071fd3fa839dc7ccbe8832f333bad52d97dc4d176c822cc1ce3d5ce0bb05d637e SHA512 47aaa63144e6a0f4d020adb54fc5f36af01848a12f8adfcbd9889825980a1479b32041c087992de5f44478cc25729d1c97ed6cb094def2b93165f0120f10c5b6
+DIST DBUtils-2.0.1.tar.gz 91789 BLAKE2B ab231000211b7a704da8cd43862830e3a6cf3e42d8053ac0391ce68b6f51f0faae9172c83db156c1d8efc8fc1e8afad9c05eee89edbe7061cc7102e84ce08683 SHA512 0e3aedce9b659e717d60106cac7c76d6d488b5629a102a714e6fe57ac162a74c787e31e984cdeb3e375b3add6539325576f68f1779b7f7ce558ba00770eeacc8
DIST DBUtils-2.0.tar.gz 92911 BLAKE2B 1822f85b9da1bd7936d01f8069deef10e8ab9b7a5c89de718071cf4783f2845357ccca0e85057d430c57f33a2a7c6d239f632032397bb1f0013a40e42383b5f1 SHA512 7818eab572db4798d0a7a2eaed6c4ba91c79c8517da56db21c07525f0097ca80c0beef1c9608b0b80c3a93f1372f37de7c8ec97f2e33dc4dc4a3d464c5981d13
diff --git a/dev-python/dbutils/dbutils-2.0.1.ebuild b/dev-python/dbutils/dbutils-2.0.1.ebuild
new file mode 100644
index 000000000000..109737f51670
--- /dev/null
+++ b/dev-python/dbutils/dbutils-2.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+MY_PN="DBUtils"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Database connections for multi-threaded environments"
+HOMEPAGE="
+ https://webwareforpython.github.io/DBUtils/
+ https://github.com/WebwareForPython/DBUtils/
+ https://pypi.org/project/DBUtils/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="OSL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ dodoc docs/*.rst
+ rm docs/*.rst || die
+ local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}