summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-22 21:57:49 +0100
committerSam James <sam@gentoo.org>2021-02-22 22:19:45 +0000
commit74a666f90d751d8ce697030d89687608380ce55f (patch)
treeba38750d1175ae81354a0fb45627b546c4fc5051 /dev-python/debtcollector
parentdev-python/pyghmi: Mark ALLARCHES (diff)
downloadgentoo-74a666f90d751d8ce697030d89687608380ce55f.tar.gz
gentoo-74a666f90d751d8ce697030d89687608380ce55f.tar.bz2
gentoo-74a666f90d751d8ce697030d89687608380ce55f.zip
dev-python/debtcollector: Port to python 3.9
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Closes: https://github.com/gentoo/gentoo/pull/19582 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/debtcollector')
-rw-r--r--dev-python/debtcollector/debtcollector-2.2.0.ebuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/dev-python/debtcollector/debtcollector-2.2.0.ebuild b/dev-python/debtcollector/debtcollector-2.2.0.ebuild
index 76b68956472d..f2d8758c6da0 100644
--- a/dev-python/debtcollector/debtcollector-2.2.0.ebuild
+++ b/dev-python/debtcollector/debtcollector-2.2.0.ebuild
@@ -2,9 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
DESCRIPTION="Python deprecation patterns and strategies that collect technical debt"
@@ -15,11 +14,8 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 x86"
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+DEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
!~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}"
-RDEPEND="
- ${CDEPEND}
+RDEPEND="${DEPEND}
>=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
-"
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]"