summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-12 09:57:53 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-12 13:34:49 +0300
commita6abb52469160bbbde0863e2a48bb97a31cf8aaa (patch)
tree137aeed554ccbd42e6bdfe30e2e956be8c34243c /dev-python/defcon
parentdev-python/cliff: add 4.0.0 (diff)
downloadgentoo-a6abb52469160bbbde0863e2a48bb97a31cf8aaa.tar.gz
gentoo-a6abb52469160bbbde0863e2a48bb97a31cf8aaa.tar.bz2
gentoo-a6abb52469160bbbde0863e2a48bb97a31cf8aaa.zip
dev-python/defcon: add 0.10.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/defcon')
-rw-r--r--dev-python/defcon/Manifest1
-rw-r--r--dev-python/defcon/defcon-0.10.2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/defcon/Manifest b/dev-python/defcon/Manifest
index f72dfb8f9ecf..3f94d2039244 100644
--- a/dev-python/defcon/Manifest
+++ b/dev-python/defcon/Manifest
@@ -1 +1,2 @@
DIST defcon-0.10.1.tar.gz 426234 BLAKE2B 0d4f0749c061860603d343bd8d0291699a64794ec8f3f1e6f1cff0af0f22cd0cfc4ae60d578c5f55131d1de694b3234017afd124a4266c972217b39d70071473 SHA512 12cb1512321b91676f8be380999dfb00942eb8355389db409ef896f7e7100fc97186a920c1c0a741b660e57134e880d068446e5ad00e2768221f80a26608819c
+DIST defcon-0.10.2.gh.tar.gz 426253 BLAKE2B 308c0f78a476db8f6fe7eb563970a91f1869a26a8a012905c70fb886d954f8b66b6952801212ddc4439921049773ef07c8f99c51465841681b2c19ab0d9ac27d SHA512 fada72ff846d377e76e259255dbb6f3170c6e87c793f891bed2b5e827ae3001864872eda92a9bb031f32194a7b61089a29908e510f6a4dece8e94828f82e1798
diff --git a/dev-python/defcon/defcon-0.10.2.ebuild b/dev-python/defcon/defcon-0.10.2.ebuild
new file mode 100644
index 000000000000..4d7c79756da6
--- /dev/null
+++ b/dev-python/defcon/defcon-0.10.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A set of UFO based objects for use in font editing applications"
+HOMEPAGE="https://github.com/robotools/defcon"
+SRC_URI="
+ https://github.com/robotools/defcon/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/fonttools-4.34.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/fs[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}