summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-14 08:52:11 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-14 08:52:11 +0100
commit5b4d9367f11a77f3f23876c00460b5ff79650bcf (patch)
treeafe8bdb809349a1afb99fc167fceb171329dde06 /dev-python/deprecated/deprecated-1.2.12.ebuild
parentdev-python/jsonpointer: Bump to 2.1 (diff)
downloadgentoo-5b4d9367f11a77f3f23876c00460b5ff79650bcf.tar.gz
gentoo-5b4d9367f11a77f3f23876c00460b5ff79650bcf.tar.bz2
gentoo-5b4d9367f11a77f3f23876c00460b5ff79650bcf.zip
dev-python/deprecated: Bump to 1.2.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/deprecated/deprecated-1.2.12.ebuild')
-rw-r--r--dev-python/deprecated/deprecated-1.2.12.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/deprecated/deprecated-1.2.12.ebuild b/dev-python/deprecated/deprecated-1.2.12.ebuild
new file mode 100644
index 000000000000..1b72f93f7450
--- /dev/null
+++ b/dev-python/deprecated/deprecated-1.2.12.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Python @deprecated decorator to deprecate old API"
+HOMEPAGE="https://github.com/tantale/deprecated"
+SRC_URI="
+ https://github.com/tantale/deprecated/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/wrapt[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=()
+
+ [[ ${EPYTHON} == pypy3 ]] && deselect+=(
+ tests/test_deprecated.py::test_respect_global_filter
+ tests/test_deprecated_class.py::test_class_respect_global_filter
+ )
+
+ pytest -vv ${deselect[@]/#/--deselect } || die "Tests failed with ${EPYTHON}"
+}