summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-06 08:03:11 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-06 08:23:22 +0200
commit2e6b0d72824c2ad2084f32b79126fc2e7eeb0136 (patch)
tree5ee0a03d57fcd3fb8fdb77801f6d277135da0d4c /dev-python/deprecated
parentdev-python/bitarray: Bump to 2.3.3 (diff)
downloadgentoo-2e6b0d72824c2ad2084f32b79126fc2e7eeb0136.tar.gz
gentoo-2e6b0d72824c2ad2084f32b79126fc2e7eeb0136.tar.bz2
gentoo-2e6b0d72824c2ad2084f32b79126fc2e7eeb0136.zip
dev-python/deprecated: Bump to 1.2.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/deprecated')
-rw-r--r--dev-python/deprecated/Manifest1
-rw-r--r--dev-python/deprecated/deprecated-1.2.13.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/deprecated/Manifest b/dev-python/deprecated/Manifest
index aabed087e350..a25e50052cd9 100644
--- a/dev-python/deprecated/Manifest
+++ b/dev-python/deprecated/Manifest
@@ -1 +1,2 @@
DIST deprecated-1.2.12.gh.tar.gz 2969891 BLAKE2B c5fe02ff2c0588c5c6fb1e9054ad7851943c4574be633aa6ae37a466b3cac9889d8ed119962fcffc2092ab844a6d18a5d72766141e149bba2ba0c2dd4ee5131b SHA512 ff9b03a35b688474b6d5390347c4acdf5e19fcee5f7fcbb61a456c6819adbcda72ce00200d55b92c65873addad5abf9d1d5617bf477f64beb08ca23f10ebaea2
+DIST deprecated-1.2.13.gh.tar.gz 2971610 BLAKE2B 00c1fad34e869b143ad7cada2426f999f1d353d23e33076b0197a7ca6c87b0f2d240d7f4944b7c7669974c89304a6cf04f5d2b4c44e6fee22c27522ec2cc9711 SHA512 c170b086bc4e37462181a0f53edbe745aa4f4924c7fd64d9693de267e070392b74445f9cba935e85c878b755603ca6cada8b4130ac96ab071be284047aa35619
diff --git a/dev-python/deprecated/deprecated-1.2.13.ebuild b/dev-python/deprecated/deprecated-1.2.13.ebuild
new file mode 100644
index 000000000000..89023d5fda4f
--- /dev/null
+++ b/dev-python/deprecated/deprecated-1.2.13.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Python @deprecated decorator to deprecate old API"
+HOMEPAGE="https://github.com/tantale/deprecated"
+SRC_URI="
+ https://github.com/tantale/deprecated/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="dev-python/wrapt[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ tests/test_deprecated.py::test_respect_global_filter
+ tests/test_deprecated_class.py::test_class_respect_global_filter
+ )
+
+ epytest
+}