summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-12 07:34:02 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-12 07:35:34 +0100
commit7bf585ea6db14ca2c31cdf4b290c6a0a10a34470 (patch)
tree9f2c09ab9c8a5011b639d5e238e2446cca82259b /dev-python/deprecated
parentprofiles/desc: Add python3_8 to PYTHON_TARGETS (diff)
downloadgentoo-7bf585ea6db14ca2c31cdf4b290c6a0a10a34470.tar.gz
gentoo-7bf585ea6db14ca2c31cdf4b290c6a0a10a34470.tar.bz2
gentoo-7bf585ea6db14ca2c31cdf4b290c6a0a10a34470.zip
dev-python/deprecated: Bump to 1.2.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/deprecated')
-rw-r--r--dev-python/deprecated/Manifest1
-rw-r--r--dev-python/deprecated/deprecated-1.2.7.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/deprecated/Manifest b/dev-python/deprecated/Manifest
index 178dcb221169..613dccd32bc4 100644
--- a/dev-python/deprecated/Manifest
+++ b/dev-python/deprecated/Manifest
@@ -1 +1,2 @@
DIST deprecated-1.2.6.gh.tar.gz 5043633 BLAKE2B cc72838dc772db62ca75637268d09cbab4c9acb84b42bd1d2d76397d43b81781cfcef075a9a6e6ca2ab55eda19acae95cdfbdd820c1363e7ea4841fb1cb61b7b SHA512 fcef322c6d9c317081dae365d469d4b26b0d23d8290e7aa0ca18592fb098ae7f535cb5e898cc81e5c734e7e211c847cdd9d5430c1999a4b9612f30934243ee9e
+DIST deprecated-1.2.7.gh.tar.gz 5044697 BLAKE2B 5e295ce21a3e536e08b6e57d78d3682b31e9041f4c53d97c06af03f8272a5b729c892449210471b80500ce499fe9e6af22df8ac0aeec5ac774fd74590ebdfc3b SHA512 da99a22410fdcc2a96cb5b15c489971078ce34e251406ae3dce6b3f97e284a4f09aaf1c5702407abe85a94cb6c8d9237f373a3096d6182e4a9cd1990be2817f1
diff --git a/dev-python/deprecated/deprecated-1.2.7.ebuild b/dev-python/deprecated/deprecated-1.2.7.ebuild
new file mode 100644
index 000000000000..b42bdd730040
--- /dev/null
+++ b/dev-python/deprecated/deprecated-1.2.7.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+inherit distutils-r1
+
+DESCRIPTION="Python @deprecated decorator to deprecate old API"
+HOMEPAGE="https://github.com/tantale/deprecated"
+SRC_URI="https://github.com/tantale/deprecated/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/wrapt[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest