summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-03-22 19:18:36 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-03-22 23:18:12 +0000
commit8d417a27cd988faf168d9fdabcca9e30215037b2 (patch)
tree25781bc1a63356fe66f13ee2df80c6b01a523e45 /dev-python/dill
parentsci-misc/fitscut: initial import (diff)
downloadgentoo-8d417a27cd988faf168d9fdabcca9e30215037b2.tar.gz
gentoo-8d417a27cd988faf168d9fdabcca9e30215037b2.tar.bz2
gentoo-8d417a27cd988faf168d9fdabcca9e30215037b2.zip
dev-python/dill: initial import
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/dill')
-rw-r--r--dev-python/dill/Manifest1
-rw-r--r--dev-python/dill/dill-0.2.5.ebuild23
-rw-r--r--dev-python/dill/files/dill-0.2.5-avoid-installation-binaries.patch29
-rw-r--r--dev-python/dill/files/dill-0.2.5-remove-install_requires.patch28
-rw-r--r--dev-python/dill/metadata.xml22
5 files changed, 103 insertions, 0 deletions
diff --git a/dev-python/dill/Manifest b/dev-python/dill/Manifest
new file mode 100644
index 000000000000..7f57e425fd9d
--- /dev/null
+++ b/dev-python/dill/Manifest
@@ -0,0 +1 @@
+DIST dill-0.2.5.tgz 60572 SHA256 431c9d46e190dcdf1397234cf659d66e2e22e33b0474ed6ee2d0b16c9c0ea319 SHA512 94942a736b4c2e1558eb9475f9bafe3a24f88a976abf9880beec386497a2bc769cb9be6bbfd2baac006c92578c372f5dfcfa165c5649876ea5076a3b207de6fc WHIRLPOOL b0af3e279ad937f36450f25711412b7e48928515e4721fee3d91663c4ec629357b6d8f3c661f1ac56d3f7343a3bef717a368386bd8983991e06a4ce0f78ae1f9
diff --git a/dev-python/dill/dill-0.2.5.ebuild b/dev-python/dill/dill-0.2.5.ebuild
new file mode 100644
index 000000000000..6ad1dd52d959
--- /dev/null
+++ b/dev-python/dill/dill-0.2.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Serialize all of python (almost)"
+HOMEPAGE="http://www.cacr.caltech.edu/~mmckerns/dill.htm"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}/${P}-avoid-installation-binaries.patch"
+ "${FILESDIR}/${P}-remove-install_requires.patch"
+)
diff --git a/dev-python/dill/files/dill-0.2.5-avoid-installation-binaries.patch b/dev-python/dill/files/dill-0.2.5-avoid-installation-binaries.patch
new file mode 100644
index 000000000000..16525c10b343
--- /dev/null
+++ b/dev-python/dill/files/dill-0.2.5-avoid-installation-binaries.patch
@@ -0,0 +1,29 @@
+From dfa34a34f09d0f868cc404d5c1ccf071f47fe63f Mon Sep 17 00:00:00 2001
+From: Josue Ortega <josueortega@debian.org.gt>
+Date: Sun, 1 Nov 2015 13:07:04 -0600
+Subject: Patch to avoid the installation of upstream binaries under the wrong
+ directories
+
+---
+ setup.py | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 8f91183..1ee6dcf 100644
+--- a/setup.py
++++ b/setup.py
+@@ -283,10 +283,10 @@ if has_setuptools:
+ """ % (ctypes_version)
+
+ # add the scripts, and close 'setup' call
+-setup_code += """
+- scripts=['scripts/unpickle.py','scripts/get_objgraph.py'])
+-"""
+-
++#setup_code += """
++# scripts=['scripts/unpickle.py','scripts/get_objgraph.py'])
++#"""
++setup_code += ")"
+ # exec the 'setup' code
+ exec(setup_code)
+
diff --git a/dev-python/dill/files/dill-0.2.5-remove-install_requires.patch b/dev-python/dill/files/dill-0.2.5-remove-install_requires.patch
new file mode 100644
index 000000000000..dfa5f0dd653d
--- /dev/null
+++ b/dev-python/dill/files/dill-0.2.5-remove-install_requires.patch
@@ -0,0 +1,28 @@
+From 9b32a0be077d5295a42fec7cb17810fa3e8aca45 Mon Sep 17 00:00:00 2001
+From: Josue Ortega <josueortega@debian.org.gt>
+Date: Sun, 1 Nov 2015 13:11:04 -0600
+Subject: Removes install_requires in order to avoid automatic package
+
+---
+ setup.py | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 1ee6dcf..dd90af5 100644
+--- a/setup.py
++++ b/setup.py
+@@ -277,10 +277,10 @@ if has_setuptools:
+ install_requires = ['pyreadline%s'],
+ """ % (pyreadline_version)
+ # verrrry unlikely that this is still relevant
+- elif hex(sys.hexversion) < '0x20500f0':
+- setup_code += """
+- install_requires = ['ctypes%s'],
+-""" % (ctypes_version)
++# elif hex(sys.hexversion) < '0x20500f0':
++# setup_code += """
++# install_requires = ['ctypes%s'],
++#""" % (ctypes_version)
+
+ # add the scripts, and close 'setup' call
+ #setup_code += """
diff --git a/dev-python/dill/metadata.xml b/dev-python/dill/metadata.xml
new file mode 100644
index 000000000000..b277396800f0
--- /dev/null
+++ b/dev-python/dill/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Dill extends Python's 'pickle' module for serializing and de-serializing Python
+ objects to the majority of the built-in Python types.
+ Dill provides the user the same interface as the 'pickle' module, and also
+ includes some additional features. In addition to pickling Python objects,
+ dill provides the ability to save the state of an interpreter session in a
+ single command.
+ Dill can be used to store Python objects to a file, but the primary usage is to
+ send Python objects across the network as a byte stream.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">dill</remote-id>
+ <remote-id type="github">uqfoundation/dill</remote-id>
+ </upstream>
+</pkgmetadata>