summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-16 08:47:52 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-16 10:18:47 +0200
commita03ec6649202416a96415bd063481e1b86695958 (patch)
treea234135b59111cb8adc305e6049cd068cfb63d05 /dev-python/dill
parentdev-python/asgiref: Port to py3.9 (diff)
downloadgentoo-a03ec6649202416a96415bd063481e1b86695958.tar.gz
gentoo-a03ec6649202416a96415bd063481e1b86695958.tar.bz2
gentoo-a03ec6649202416a96415bd063481e1b86695958.zip
dev-python/dill: Bump to 0.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dill')
-rw-r--r--dev-python/dill/Manifest1
-rw-r--r--dev-python/dill/dill-0.3.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/dill/Manifest b/dev-python/dill/Manifest
index 926656922954..27046d216612 100644
--- a/dev-python/dill/Manifest
+++ b/dev-python/dill/Manifest
@@ -1 +1,2 @@
DIST dill-0.3.1.1.tar.gz 151986 BLAKE2B 71b364730805974117cb00965a2276aa240b6265f2a98ae8e70ca2f9d8bf7a4b801fac083f2395932fdc016de3f068fb46091f296910ce96725bc982e774a40a SHA512 e61610451972522316d7ed6bc8287e38521fcd2e6736b43200ae498f24596994caec92313be1da71cf1b536fbbe01505673fc8018bfcbaf7705147a294565ab9
+DIST dill-0.3.2.gh.tar.gz 148972 BLAKE2B a807350a2d2bb84e705d20c9c60d47834b41863b862a5d347ebc32273c1b9479c568cd3018126adb1cd052bb00f50e8424f7118b37524329458150b9a3e59e3d SHA512 74a0c01dd7c0126c7de21a3b3660e51486fec17f64f23b8e7f23b70243209908573fef8851f6eda53868e89ef1a8a5e351a3ef81dd9cb3e122a2dba33a86bbe1
diff --git a/dev-python/dill/dill-0.3.2.ebuild b/dev-python/dill/dill-0.3.2.ebuild
new file mode 100644
index 000000000000..32554341e099
--- /dev/null
+++ b/dev-python/dill/dill-0.3.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Serialize all of python (almost)"
+HOMEPAGE="https://pypi.org/project/dill/"
+SRC_URI="
+ https://github.com/uqfoundation/dill/archive/${P}.tar.gz
+ -> ${P}.gh.tar.gz"
+S=${WORKDIR}/${PN}-${P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+python_test() {
+ local fail= t
+ for t in tests/test_*.py; do
+ ebegin "\t${t}"
+ "${EPYTHON}" "${t}"
+ eend || fail=1
+ done
+
+ [[ ${fail} ]] && die "Tests fail with ${EPYTHON}"
+}