summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-08-24 22:43:37 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-08-25 00:32:47 +0200
commit98e523fcd420fc29d9e800ba1621af285ac970b0 (patch)
tree949f6ac60a6646732acb06b2220358215dc69ce6 /dev-python/dissononce
parentdev-python/transitions: drop old version (diff)
downloadgentoo-98e523fcd420fc29d9e800ba1621af285ac970b0.tar.gz
gentoo-98e523fcd420fc29d9e800ba1621af285ac970b0.tar.bz2
gentoo-98e523fcd420fc29d9e800ba1621af285ac970b0.zip
dev-python/dissononce: add python3.9 support
Also adjusted test deps and enabled tests. Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-python/dissononce')
-rw-r--r--dev-python/dissononce/dissononce-0.34.3-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/dissononce/dissononce-0.34.3-r1.ebuild b/dev-python/dissononce/dissononce-0.34.3-r1.ebuild
new file mode 100644
index 000000000000..57475f3014d1
--- /dev/null
+++ b/dev-python/dissononce/dissononce-0.34.3-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python implementation for Noise Protocol Framework"
+HOMEPAGE="https://github.com/tgalal/dissononce"
+SRC_URI="https://github.com/tgalal/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="examples test"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/transitions[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-fix-test-requirements.patch" )
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+
+ use examples && dodoc examples/patterns/*.py
+}