summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-04-06 08:35:26 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-04-06 08:38:06 +0300
commit7622f900c65bed93baa22c98c8b09cce1af77e64 (patch)
treefdb9fda6b1291d0ed16223e0968f7ab337335890 /dev-python/distlib
parentnet-news/newsboat: unmaintain (diff)
downloadgentoo-7622f900c65bed93baa22c98c8b09cce1af77e64.tar.gz
gentoo-7622f900c65bed93baa22c98c8b09cce1af77e64.tar.bz2
gentoo-7622f900c65bed93baa22c98c8b09cce1af77e64.zip
dev-python: mass last-rites removal
Closes: https://bugs.gentoo.org/711808 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'dev-python/distlib')
-rw-r--r--dev-python/distlib/Manifest2
-rw-r--r--dev-python/distlib/distlib-0.2.1.ebuild27
-rw-r--r--dev-python/distlib/distlib-0.2.4.ebuild53
-rw-r--r--dev-python/distlib/files/distlib-0.2.2-unbundle.patch35
-rw-r--r--dev-python/distlib/metadata.xml13
5 files changed, 0 insertions, 130 deletions
diff --git a/dev-python/distlib/Manifest b/dev-python/distlib/Manifest
deleted file mode 100644
index 6844deed642c..000000000000
--- a/dev-python/distlib/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST distlib-0.2.1.zip 542424 BLAKE2B 241b14519499b76beaa8994b30be8b78ea83f3073668174f4e2e02cc9609feb957b3b4fdb59e68943223e6fb8d0251a8bab990396c4e4297c683ab4eda8fbcc9 SHA512 f6453585650db242ad4a176bbd468cc6069ee0941b6ea23f24fc32000778097d8a100de82eaad7b3d8d998dc153d25f537505c7eefcc6f98f37995cfc9d5be77
-DIST distlib-0.2.4.zip 547411 BLAKE2B 763027059faccdcee682d5eddbdeb2c23cfefff178d992db811233b48d7a4d605626f8619d51dacc55ae5a016557e528b0bec0c625258e469f2fd98a9a659c6b SHA512 03f9f9474578226e1a40a85a490aead3ec0509ba444856a263d4f25b3c86b5f919a3e18ff715a3a329d80a3f20a540b8c57a6e3dff55703c9cce730e2d021084
diff --git a/dev-python/distlib/distlib-0.2.1.ebuild b/dev-python/distlib/distlib-0.2.1.ebuild
deleted file mode 100644
index cb690cca304c..000000000000
--- a/dev-python/distlib/distlib-0.2.1.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Distribution utilities"
-HOMEPAGE="https://pypi.org/project/distlib/ https://bitbucket.org/vinay.sajip/distlib https://github.com/vsajip/distlib"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-DEPEND="app-arch/unzip"
-
-python_test() {
- sed \
- -e '/PIP_AVAILABLE/s:True:False:g' \
- -i tests/*py || die
- PYTHONHASHSEED=0 esetup.py test
-}
diff --git a/dev-python/distlib/distlib-0.2.4.ebuild b/dev-python/distlib/distlib-0.2.4.ebuild
deleted file mode 100644
index ad59c38fff23..000000000000
--- a/dev-python/distlib/distlib-0.2.4.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Distribution utilities"
-HOMEPAGE="https://pypi.org/project/distlib/ https://bitbucket.org/vinay.sajip/distlib https://github.com/vsajip/distlib"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-DEPEND="app-arch/unzip"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.2.2-unbundle.patch
-)
-
-python_prepare_all() {
- rm -r \
- distlib/*.exe \
- distlib/_backport \
- tests/test_shutil.py* \
- tests/test_sysconfig.py* || die
-
- distutils-r1_python_prepare_all
-
- # Broken tests
- # 1 fails due to it being sensitive to dictionary ordering
- # inconsistency between code and test
- sed \
- -e 's:test_dependency_finder:_&:g' \
- -i tests/*py || die
-
- # Gentoo still doesn't report correct ABI
- sed \
- -e 's:test_abi:_&:g' \
- -i tests/*py || die
-}
-
-python_test() {
- sed \
- -e '/PIP_AVAILABLE/s:True:False:g' \
- -i tests/*py || die
- SKIP_ONLINE=True PYTHONHASHSEED=0 esetup.py test
-}
diff --git a/dev-python/distlib/files/distlib-0.2.2-unbundle.patch b/dev-python/distlib/files/distlib-0.2.2-unbundle.patch
deleted file mode 100644
index 5ee912905602..000000000000
--- a/dev-python/distlib/files/distlib-0.2.2-unbundle.patch
+++ /dev/null
@@ -1,35 +0,0 @@
---- distlib-0.1.9/distlib/compat.py.orig 2014-06-06 09:58:21.317560756 +0200
-+++ distlib-0.1.9/distlib/compat.py 2014-06-06 09:58:29.955611427 +0200
-@@ -17,7 +17,7 @@ if sys.version_info[0] < 3:
- from types import FileType as file_type
- import __builtin__ as builtins
- import ConfigParser as configparser
-- from ._backport import shutil
-+ import shutil
- from urlparse import urlparse, urlunparse, urljoin, urlsplit, urlunsplit
- from urllib import (urlretrieve, quote as _quote, unquote, url2pathname,
- pathname2url, ContentTooShortError, splittype)
-@@ -267,7 +267,7 @@ except ImportError: # pragma: no cover
- try:
- import sysconfig
- except ImportError: # pragma: no cover
-- from ._backport import sysconfig
-+ import sysconfig
-
- try:
- callable = callable
---- distlib-0.1.9/setup.py.orig 2014-06-06 10:19:13.971997156 +0200
-+++ distlib-0.1.9/setup.py 2014-06-06 10:19:20.012034150 +0200
-@@ -62,12 +62,7 @@ distutils.core.setup(
- platforms='any',
- packages=[
- 'distlib',
-- 'distlib._backport',
- ],
-- package_data={
-- 'distlib._backport': ['sysconfig.cfg'],
-- 'distlib': ['t32.exe', 't64.exe', 'w32.exe', 'w64.exe'],
-- },
- cmdclass={
- 'test': TestCommand,
- },
diff --git a/dev-python/distlib/metadata.xml b/dev-python/distlib/metadata.xml
deleted file mode 100644
index f095796ff078..000000000000
--- a/dev-python/distlib/metadata.xml
+++ /dev/null
@@ -1,13 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">distlib</remote-id>
- <remote-id type="github">vsajip/distlib</remote-id>
- <remote-id type="bitbucket">vinay.sajip/distlib</remote-id>
- </upstream>
-</pkgmetadata>