summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-02-18 17:03:01 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-02-18 18:04:36 +0100
commit5ceba41bae658845448b8684626d832c7a780486 (patch)
tree3489f33501854219bebd602e9c40d54ef308a327 /dev-python/dj-database-url/dj-database-url-0.4.0.ebuild
parentdev-java/java-config: Remove java-config-wrapper dependency, EAPI bump (diff)
downloadgentoo-5ceba41bae658845448b8684626d832c7a780486.tar.gz
gentoo-5ceba41bae658845448b8684626d832c7a780486.tar.bz2
gentoo-5ceba41bae658845448b8684626d832c7a780486.zip
dev-python/dj-database-url: Bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/dj-database-url/dj-database-url-0.4.0.ebuild')
-rw-r--r--dev-python/dj-database-url/dj-database-url-0.4.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/dj-database-url/dj-database-url-0.4.0.ebuild b/dev-python/dj-database-url/dj-database-url-0.4.0.ebuild
new file mode 100644
index 000000000000..e9320c52bb5c
--- /dev/null
+++ b/dev-python/dj-database-url/dj-database-url-0.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Use Database URLs in your Django Application"
+HOMEPAGE="https://pypi.python.org/pypi/dj-database-url https://github.com/kennethreitz/dj-database-url"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# Not contained in the tarball
+RESTRICT=test
+
+python_test() {
+ "${PYTHON}" test_dj_database_url.py || die
+}