summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2021-05-22 13:07:36 +0300
committerMichał Górny <mgorny@gentoo.org>2021-05-22 20:18:11 +0200
commit3c8c57663d434d4d39bbd6cec72a08ce3611b9f6 (patch)
treed0fc0e5b83d133489919dbe0a8e9e5d4c84acd38 /dev-python/dj-email-url
parentdev-python/apispec: drop 3.3.0, 4.2.0, 4.3.0, 4.4.0 (diff)
downloadgentoo-3c8c57663d434d4d39bbd6cec72a08ce3611b9f6.tar.gz
gentoo-3c8c57663d434d4d39bbd6cec72a08ce3611b9f6.tar.bz2
gentoo-3c8c57663d434d4d39bbd6cec72a08ce3611b9f6.zip
dev-python/dj-email-url: bump to python 3.10
passes tests Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dj-email-url')
-rw-r--r--dev-python/dj-email-url/dj-email-url-1.0.2.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/dev-python/dj-email-url/dj-email-url-1.0.2.ebuild b/dev-python/dj-email-url/dj-email-url-1.0.2.ebuild
index e101e12aff3d..40c4d515ab1f 100644
--- a/dev-python/dj-email-url/dj-email-url-1.0.2.ebuild
+++ b/dev-python/dj-email-url/dj-email-url-1.0.2.ebuild
@@ -1,10 +1,9 @@
# Copyright 2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
@@ -15,10 +14,9 @@ SRC_URI="https://github.com/migonzalvar/dj-email-url/archive/refs/tags/v${PV}.ta
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
DOCS=( CHANGELOG.rst README.rst )
python_test() {
- "${PYTHON:-python}" test_dj_email_url.py || die
+ "${EPYTHON}" test_dj_email_url.py -v || die "Tests failed with ${EPYTHON}"
}