summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-25 21:34:07 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-25 21:53:56 +0100
commit95c5a4985a0e03f4af7879fe82591de632af38ee (patch)
treea8ce49a3e337bfde895b0d4dc317f3ebd8d7b821 /dev-python/django-auth-ldap
parentdev-python/django-appconf: Remove Python 2 (diff)
downloadgentoo-95c5a4985a0e03f4af7879fe82591de632af38ee.tar.gz
gentoo-95c5a4985a0e03f4af7879fe82591de632af38ee.tar.bz2
gentoo-95c5a4985a0e03f4af7879fe82591de632af38ee.zip
dev-python/django-auth-ldap: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-auth-ldap')
-rw-r--r--dev-python/django-auth-ldap/Manifest2
-rw-r--r--dev-python/django-auth-ldap/django-auth-ldap-1.2.2.ebuild44
-rw-r--r--dev-python/django-auth-ldap/django-auth-ldap-1.2.7.ebuild42
-rw-r--r--dev-python/django-auth-ldap/files/docs.patch18
4 files changed, 0 insertions, 106 deletions
diff --git a/dev-python/django-auth-ldap/Manifest b/dev-python/django-auth-ldap/Manifest
index 2e3cdb85c954..2782051a1800 100644
--- a/dev-python/django-auth-ldap/Manifest
+++ b/dev-python/django-auth-ldap/Manifest
@@ -1,3 +1 @@
-DIST django-auth-ldap-1.2.2.tar.gz 131086 BLAKE2B 78f93eb24620907f5b5671972e2b80ec6e59cdc42a455c298bef4c3215616228735a0647b0646b683357bc16ea6d03488aa86626e2ad51211a382ee2d0482909 SHA512 676d1114faeb9a2956ed51c586afea7618c1bf62867d3525596599391f8327b8f22a075c4203311df88279c317ca37b9097b59e55a64330afee6eb1c5a9c9ac3
-DIST django-auth-ldap-1.2.7.tar.gz 131431 BLAKE2B 03fac590118d25ad0d9d8a3ac5dd8bb24f138f193bf27ae85d4e2776be79bb31ca7efb278fd05ca1d45976116ca7ec79ec3b510ca380dd8912ce47f1522ad348 SHA512 2ca29bdceb4b2540f7c90c9dfdfd7a02f91e72cd44ae062cebff84199dab737ee69ada56269189ec0dd70ee7916c3373acba50866280ad080c4c68dd69dffb09
DIST django-auth-ldap-1.7.0.tar.gz 48897 BLAKE2B b4b196e4cd0882a48d2437326cda57394963fa44a64a3cf5a0ff668bb86243da3979e2746e096a458a5bf1d3c8be687f3d3fe456f5a6b0ada11ebd1f4787e323 SHA512 6478b2ef43e6f49acff3dd2e3a2a462ae02a3f1475d5615ba2f14bfd5efe2b232a3d2008902177d90822fea6b096a05814a5f028f4eec5ee09c5e5a62793e73d
diff --git a/dev-python/django-auth-ldap/django-auth-ldap-1.2.2.ebuild b/dev-python/django-auth-ldap/django-auth-ldap-1.2.2.ebuild
deleted file mode 100644
index e75848f809c8..000000000000
--- a/dev-python/django-auth-ldap/django-auth-ldap-1.2.2.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-# Although setup.py claims to support py3, python-ldap does not
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Django LDAP authentication backend"
-HOMEPAGE="https://pypi.org/project/django-auth-ldap/ https://bitbucket.org/psagers/django-auth-ldap/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-LICENSE="BSD"
-SLOT="0"
-
-RDEPEND="dev-python/django[${PYTHON_USEDEP}]
- >=dev-python/python-ldap-2.0[${PYTHON_USEDEP}]"
-DEPEND="app-arch/unzip
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- >=dev-python/mockldap-0.2[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-#S="${WORKDIR}"/psagers-${PN}-80379ce59e6b
-
-PATCHES=( "${FILESDIR}"/docs.patch )
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- PYTHONPATH=. "${PYTHON}" test/manage.py test || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/django-auth-ldap/django-auth-ldap-1.2.7.ebuild b/dev-python/django-auth-ldap/django-auth-ldap-1.2.7.ebuild
deleted file mode 100644
index db72fc552b7f..000000000000
--- a/dev-python/django-auth-ldap/django-auth-ldap-1.2.7.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-# Although setup.py claims to support py3, python-ldap does not
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Django LDAP authentication backend"
-HOMEPAGE="https://pypi.org/project/django-auth-ldap/ https://bitbucket.org/psagers/django-auth-ldap/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-LICENSE="BSD"
-SLOT="0"
-
-RDEPEND="dev-python/django[${PYTHON_USEDEP}]
- >=dev-python/python-ldap-2.0[${PYTHON_USEDEP}]"
-DEPEND="app-arch/unzip
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- >=dev-python/mockldap-0.2[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}"/docs.patch )
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- PYTHONPATH=. "${PYTHON}" test/manage.py test || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/django-auth-ldap/files/docs.patch b/dev-python/django-auth-ldap/files/docs.patch
deleted file mode 100644
index c4e918fac538..000000000000
--- a/dev-python/django-auth-ldap/files/docs.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Avoid unwanted d'loading for un-needed ojects.inv files
-diff -ur django-auth-ldap-1.1.4.orig/docs/source/conf.py django-auth-ldap-1.1.4/docs/source/conf.py
---- docs/source/conf.py 2013-03-10 06:01:09.000000000 +0800
-+++ docs/source/conf.py 2013-05-18 23:14:35.761187583 +0800
-@@ -29,13 +29,6 @@
- 'daldocs',
- ]
-
--intersphinx_mapping = {
-- 'python': ('http://docs.python.org/', None),
-- 'django': ('https://docs.djangoproject.com/en/dev/',
-- 'https://docs.djangoproject.com/en/dev/_objects/'),
-- 'pythonldap': ('http://python-ldap.org/doc/html/', None),
--}
--
- # Add any paths that contain templates here, relative to this directory.
- templates_path = ['../_templates']
-