summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-11 08:28:48 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-11 08:28:48 +0200
commit89e3bb97257bad6e675968c2279253022ab277a7 (patch)
tree56883a4e0832ea327ab759c7e3572cd01bacfdfc /dev-python/django-cacheops
parentdev-python/pytables: Backport cython-3 fix (diff)
downloadgentoo-89e3bb97257bad6e675968c2279253022ab277a7.tar.gz
gentoo-89e3bb97257bad6e675968c2279253022ab277a7.tar.bz2
gentoo-89e3bb97257bad6e675968c2279253022ab277a7.zip
dev-python/django-cacheops: Bump to 7.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-cacheops')
-rw-r--r--dev-python/django-cacheops/Manifest1
-rw-r--r--dev-python/django-cacheops/django-cacheops-7.0.1.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/django-cacheops/Manifest b/dev-python/django-cacheops/Manifest
index a6d48b49ffcf..5441631c9741 100644
--- a/dev-python/django-cacheops/Manifest
+++ b/dev-python/django-cacheops/Manifest
@@ -1 +1,2 @@
+DIST django-cacheops-7.0.1.tar.gz 70830 BLAKE2B a90c5b145475f9942de5fee4403c5d237a6754026a0e581d1cab56a1b538cbb041fa50fcc67b0a7c922274c49b510d833e2924d8744e62e5a71149d6ddd6144d SHA512 a73b24acd668d9104b8b8f27859d643ea9b80bf53375389cb21b2bbd3d97ea508f826752df2fa5ed576e91a35ba5c6cfb0e8dded772b2c47babf739e6b26dd38
DIST django-cacheops-7.0.gh.tar.gz 56009 BLAKE2B 7829c6308db163dce5e75170093107c5a9d7dc6c5caccdea55b81631f43664ddea767ce9320221abdfc9c52af6bea363a62b5e7e86e0afa54208fabf3baf431a SHA512 bae0005e377ab8d9f9dc6da50a845966affc75b57846eb432bd7090f20b644e1b7ce9e963a9b6e84270661c23a51c7cf0436fc8448d34fb3c2f3f3245f98f7f7
diff --git a/dev-python/django-cacheops/django-cacheops-7.0.1.ebuild b/dev-python/django-cacheops/django-cacheops-7.0.1.ebuild
new file mode 100644
index 000000000000..59f2aaf7ab0e
--- /dev/null
+++ b/dev-python/django-cacheops/django-cacheops-7.0.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="ORM cache with automatic granular event-driven invalidation for Django"
+HOMEPAGE="
+ https://github.com/Suor/django-cacheops/
+ https://pypi.org/project/django-cacheops/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+ >=dev-python/redis-2.9.1[${PYTHON_USEDEP}]
+ >=dev-python/funcy-1.8[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-db/redis
+ dev-python/dill[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ # Remove test dependent on unpackaged before_after
+ sed -e 's/test_lock/_&/' -i tests/test_extras.py || die
+ # Remove upper bounds on dependencies
+ sed -i -e 's:,<[0-9]*::' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x DJANGO_SETTINGS_MODULE=tests.settings
+ local -x PYTHONPATH=.
+ django-admin test -v 2 || die
+}
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ "${EPREFIX}"/usr/sbin/redis-server - <<-EOF || die
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ EOF
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}