summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-01-30 20:21:41 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-01-30 21:26:29 +0100
commitca3cda1a64a25fc4995c56a91e375d6c896735a9 (patch)
treef6a81cda2c4d7d02e8e1ca489da12e661a486ac3 /dev-python/django-cacheops
parentdev-python/funcy: add python3_9 support (diff)
downloadgentoo-ca3cda1a64a25fc4995c56a91e375d6c896735a9.tar.gz
gentoo-ca3cda1a64a25fc4995c56a91e375d6c896735a9.tar.bz2
gentoo-ca3cda1a64a25fc4995c56a91e375d6c896735a9.zip
dev-python/django-cacheops: bump to version 5.1
Also added python3_9 support. Closes: https://bugs.gentoo.org/766992 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-python/django-cacheops')
-rw-r--r--dev-python/django-cacheops/Manifest1
-rw-r--r--dev-python/django-cacheops/django-cacheops-5.1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/django-cacheops/Manifest b/dev-python/django-cacheops/Manifest
index 0a004a7eddb7..d000cc968147 100644
--- a/dev-python/django-cacheops/Manifest
+++ b/dev-python/django-cacheops/Manifest
@@ -1 +1,2 @@
DIST django-cacheops-4.2.tar.gz 50240 BLAKE2B 87ef35097f3c521ac21e614adf3b05d871b562d2a463921ba70ce3f7f4a4f7c1b6966e27077dd95016f10649cc1127fe1f7f65bd6353f86cc4395c59d20ea60e SHA512 8caa9b9ffed45bbc6039cb14ce311f714160aca2111408ae1505bbd78d0b8b4057e9414994bd0d0c1334392e83b4c27ca59e0ac1db01e3a56c409f2806bdaa27
+DIST django-cacheops-5.1.tar.gz 67776 BLAKE2B d89ac7aeccecdb69e02e03a46c9d4250439319a840f4902a51909c762cdcb8b422c2b2be2921ac256cf4a3d3248782ece0378c19b99109038b2f4e2262c57bcd SHA512 c7c5b284af4a7ec4faf88613de8eaf2bee298208ef13efbb4bb337c1e71817f36afe51ae4cbfa566a999e2dcf1361f84684189d9748a08de32675820f8b9c91b
diff --git a/dev-python/django-cacheops/django-cacheops-5.1.ebuild b/dev-python/django-cacheops/django-cacheops-5.1.ebuild
new file mode 100644
index 000000000000..2bcc4a8d1943
--- /dev/null
+++ b/dev-python/django-cacheops/django-cacheops-5.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="ORM cache with automatic granular event-driven invalidation for Django"
+HOMEPAGE="https://github.com/Suor/django-cacheops"
+SRC_URI="mirror://pypi/${PN:0:1}"/${PN}/${P}.tar.gz
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >=dev-python/django-1.8[${PYTHON_USEDEP}]
+ >=dev-python/redis-py-2.9.1[${PYTHON_USEDEP}]
+ >=dev-python/funcy-1.8[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+"
+
+RDEPEND="${DEPEND}"