summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlawomir Lis <slis@gentoo.org>2016-06-13 08:34:41 +0200
committerSlawomir Lis <slis@gentoo.org>2016-06-13 08:50:34 +0200
commit88dc88343500c6c9116c853ff01b544f11ffc1cb (patch)
tree6507eec9150e7f9f1ddb5316b3e2f52ce76cbc0b /dev-python/django-cms/django-cms-3.3.0.ebuild
parentmedia-libs/opencollada: cleaning after github pr (diff)
downloadgentoo-88dc88343500c6c9116c853ff01b544f11ffc1cb.tar.gz
gentoo-88dc88343500c6c9116c853ff01b544f11ffc1cb.tar.bz2
gentoo-88dc88343500c6c9116c853ff01b544f11ffc1cb.zip
version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-python/django-cms/django-cms-3.3.0.ebuild')
-rw-r--r--dev-python/django-cms/django-cms-3.3.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/django-cms/django-cms-3.3.0.ebuild b/dev-python/django-cms/django-cms-3.3.0.ebuild
new file mode 100644
index 000000000000..948b77cbf9bb
--- /dev/null
+++ b/dev-python/django-cms/django-cms-3.3.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_{6,7},3_{3,4}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django application for managing hierarchical pages of content"
+HOMEPAGE="https://www.django-cms.org/"
+SRC_URI="https://github.com/divio/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="+admin-style +ckeditor file flash inherit link picture snippet teaser video"
+REQUIRED_USE="admin-style ckeditor"
+
+RDEPEND="
+ >=dev-python/django-1.6.9
+ admin-style? ( >=dev-python/djangocms-admin-style-1.0 )
+ file? ( dev-python/djangocms-file )
+ flash? ( dev-python/djangocms-flash )
+ inherit? ( dev-python/djangocms-inherit )
+ link? ( dev-python/djangocms-link )
+ picture? ( dev-python/djangocms-picture )
+ snippet? ( dev-python/djangocms-snippet )
+ teaser? ( dev-python/djangocms-teaser )
+ video? ( dev-python/djangocms-video )
+ >=dev-python/django-classy-tags-0.7
+ >=dev-python/django-formtools-1.0
+ >=dev-python/django-sekizai-0.7
+ ckeditor? ( >=dev-python/djangocms-text-ckeditor-2.1.1 )
+ >=dev-python/django-treebeard-4.0
+ dev-python/html5lib
+"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools
+"