summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-14 10:52:45 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-14 10:53:37 +0100
commit848bd2188dba9079f4725476606a3173cad25cd8 (patch)
treef238af50ea289a5b89acdb1b95964a115eb21910 /dev-python/django-crispy-forms
parentdev-python/pyzmq: Version Bump (diff)
downloadgentoo-848bd2188dba9079f4725476606a3173cad25cd8.tar.gz
gentoo-848bd2188dba9079f4725476606a3173cad25cd8.tar.bz2
gentoo-848bd2188dba9079f4725476606a3173cad25cd8.zip
dev-python/django-crispy-forms: Version Bump
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/django-crispy-forms')
-rw-r--r--dev-python/django-crispy-forms/Manifest1
-rw-r--r--dev-python/django-crispy-forms/django-crispy-forms-1.6.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/django-crispy-forms/Manifest b/dev-python/django-crispy-forms/Manifest
index a500db15a129..4e619e23dfa6 100644
--- a/dev-python/django-crispy-forms/Manifest
+++ b/dev-python/django-crispy-forms/Manifest
@@ -2,3 +2,4 @@ DIST django-crispy-forms-1.4.0.tar.gz 47444 SHA256 d0c9531ebdff8dc255f625e677ec2
DIST django-crispy-forms-1.5.0.tar.gz 73736 SHA256 888d95b332247092e53f1cbe0b1fa64dd348637ec84c327bab1a7c6d6a423739 SHA512 82146e0fe00ddcb0f629a238d48142ef487cb085191815f60a4d0ecfc78c494240e07cec463462a6c53f5a83de3eb15ea555fb3cbc36301fe3656c02efaa2596 WHIRLPOOL 605fc9e715d93536c9f742bcfe19c269ccfe2e1e5dddfd80921efc15ac93366fd10db054658a0d32eea4e6ec740b2c4235d0fd542af8909fa3b1bfa387067014
DIST django-crispy-forms-1.5.1.tar.gz 114221 SHA256 f1f1d8cabb2cc2aa3a2e7c72d233d52b89895168ffd8fd6d4ecb20f465b72d29 SHA512 67eab10ffbfcaf64fa730e45bb1b03799010f0bdad3f2fd7a00847431453b4d126d7486d3c5a8cc951a22f042a8c1cc4120f11b320f5b0da9a7c42ae7059963f WHIRLPOOL b31a6814c886f41bac307bafd61a455876a7e1d25246bc72d8f9189a55747637d40d2000305d4c79972c6cf05f20108c011b7ee66e0bfd85491a36a6ee5d75c5
DIST django-crispy-forms-1.5.2.tar.gz 114239 SHA256 47ef7f74003b2a07a78ce6ed70b6472bf30efd7f8c3ef15fe0ca6685be2e0dfb SHA512 35c0aedc9d118512c23fc3cb255fd54e7af6ced7a65fbcb5c0a0dd63e1afecebe92f06c2e674815167ec7c09ad130bd6db642054b13d800e1cb1911b1e7b10e9 WHIRLPOOL e7ada1b0114bd49925c3106cd05c72bf1a961ed9f931066c8461b8254e59abfafb20112b33ced13a1a2ca680df05e4ca928fa20f657e8770497ce07eacd8632f
+DIST django-crispy-forms-1.6.0.tar.gz 118917 SHA256 67fbb7194bd9887d663161405c623f5f5cd3f9ee627515c4de7a50e16fa44ed1 SHA512 8fa46366d2f3376f4190c219a624eaf983c19243db25d6c1723917ab5f8c2d9087e2228f3208df8bd35ba26abe00f6cef46e1e3ca0c0097282d292a217f977f8 WHIRLPOOL 4b1ab48f49edf019151b8ca42e5d0ea34ad310690e929b6c8579773a7adadeffec685285f8310c20cbac4d71edcfebdd9f2ddd709ebcfef57a75f8f139e7aff6
diff --git a/dev-python/django-crispy-forms/django-crispy-forms-1.6.0.ebuild b/dev-python/django-crispy-forms/django-crispy-forms-1.6.0.ebuild
new file mode 100644
index 000000000000..b87d00a21469
--- /dev/null
+++ b/dev-python/django-crispy-forms/django-crispy-forms-1.6.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Best way to have Django DRY forms"
+HOMEPAGE="
+ https://pypi.python.org/pypi/django-crispy-forms/
+ https://github.com/maraujop/django-crispy-forms
+ https://django-crispy-forms.readthedocs.org/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# Seems to be incompletely packed
+RESTRICT=test
+
+python_test() {
+ DJANGO_SETTINGS_MODULE=crispy_forms.tests.test_settings py.test crispy_forms/tests || die
+}