summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-08-18 22:30:25 +0200
committerJustin Lecher <jlec@gentoo.org>2015-08-18 22:30:30 +0200
commitf2b7a29134d4a642f5a71ace2470b37eea02f4d4 (patch)
tree8b9724cf2560ea5058e28f8fc209f9eb4a0ce00b /dev-python/django-crispy-forms
parentsys-cluster/galera: Version bump; Fix HOMEPAGE on new version (diff)
downloadgentoo-f2b7a29134d4a642f5a71ace2470b37eea02f4d4.tar.gz
gentoo-f2b7a29134d4a642f5a71ace2470b37eea02f4d4.tar.bz2
gentoo-f2b7a29134d4a642f5a71ace2470b37eea02f4d4.zip
dev-python/django-crispy-forms: Version Bump
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/django-crispy-forms')
-rw-r--r--dev-python/django-crispy-forms/Manifest1
-rw-r--r--dev-python/django-crispy-forms/django-crispy-forms-1.5.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/django-crispy-forms/Manifest b/dev-python/django-crispy-forms/Manifest
index 55e86a9b03be..cd77ad4e6d5e 100644
--- a/dev-python/django-crispy-forms/Manifest
+++ b/dev-python/django-crispy-forms/Manifest
@@ -1 +1,2 @@
DIST django-crispy-forms-1.4.0.tar.gz 47444 SHA256 d0c9531ebdff8dc255f625e677ec2fab326522e3f4cd8f7a3e891d773d281510 SHA512 e06ec72a2fc44aa0f57fd507230289f78caebdb02d4af9adafd4b09a29b1df1be5301f3883c8b9007ecd0722683395451bbc382060eca5a459ddf6ef9edc2e1b WHIRLPOOL 05813292a863c69b3b0296ea7a7912bb8ca0f673fc07eaeff5053def516dc2b836725c7559e98cd8aa7ad59d4d686b2ff04bc53b027ea53413ea2329fa04e42d
+DIST django-crispy-forms-1.5.0.tar.gz 73736 SHA256 888d95b332247092e53f1cbe0b1fa64dd348637ec84c327bab1a7c6d6a423739 SHA512 82146e0fe00ddcb0f629a238d48142ef487cb085191815f60a4d0ecfc78c494240e07cec463462a6c53f5a83de3eb15ea555fb3cbc36301fe3656c02efaa2596 WHIRLPOOL 605fc9e715d93536c9f742bcfe19c269ccfe2e1e5dddfd80921efc15ac93366fd10db054658a0d32eea4e6ec740b2c4235d0fd542af8909fa3b1bfa387067014
diff --git a/dev-python/django-crispy-forms/django-crispy-forms-1.5.0.ebuild b/dev-python/django-crispy-forms/django-crispy-forms-1.5.0.ebuild
new file mode 100644
index 000000000000..c46101be76dd
--- /dev/null
+++ b/dev-python/django-crispy-forms/django-crispy-forms-1.5.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Best way to have Django DRY forms"
+HOMEPAGE="https://pypi.python.org/pypi/django-crispy-forms/ http://github.com/maraujop/django-crispy-forms https://django-crispy-forms.readthedocs.org/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ cd crispy_forms/tests || die
+ ${PYTHON} runtests.py || die
+}