summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/django-evolution
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/django-evolution')
-rw-r--r--dev-python/django-evolution/Manifest3
-rw-r--r--dev-python/django-evolution/django-evolution-0.6.9.ebuild47
-rw-r--r--dev-python/django-evolution/django-evolution-0.7.4.ebuild37
-rw-r--r--dev-python/django-evolution/django-evolution-0.7.5.ebuild37
-rw-r--r--dev-python/django-evolution/metadata.xml12
5 files changed, 136 insertions, 0 deletions
diff --git a/dev-python/django-evolution/Manifest b/dev-python/django-evolution/Manifest
new file mode 100644
index 000000000000..bf5d009b450b
--- /dev/null
+++ b/dev-python/django-evolution/Manifest
@@ -0,0 +1,3 @@
+DIST django_evolution-0.6.9.tar.gz 65021 SHA256 7a526b1a39e07dd3df3612986896bd8bd5e7dd42a38a9779ce749a4e8f3015f4 SHA512 f3e0925546210bdcb622ed7e51ed6e032acfc721bee9dbd7ba96b4280b36c978657c8b3d68d17799c3cc654796f8cb4d7f6c05f6eaa49840471b7f1f5dc96651 WHIRLPOOL 043a1beb21c19765cbc207ba0ef5b2c1543ee78d2c6066dbf1b53f7c877783aa50d0193eab01547db38297204969a862e3330ca22865f1903f6d06b12983bfae
+DIST django_evolution-0.7.4.tar.gz 88467 SHA256 0b75bf163d5c859f171baf674503dfb3ca7d1d2ef082e5c5952d52b9ee6644e4 SHA512 6a6596211da7c0df1690e969b6116ee86ef2645886aab3d2026c1eadc0663f58f8c4025ffc30bb5b11f2f7ccedc687702396244c8fb12f1ea12b026521f90803 WHIRLPOOL e9f35d9c0ca8f8e199d1da3092904e38ec9e72e9602e342d7e5c0b20542d7f9ff591fae1b6a39b5703bb73a0822ae7f317d32f592301153aac7bbf7c56ef530b
+DIST django_evolution-0.7.5.tar.gz 89551 SHA256 db9ee54849ccce54736b18926bd3b839d5a0e61a713263851d3e220c49e96ce1 SHA512 f457fa53ff59bff09fa3fc3ad73ffc8f09ce306c756b022d2da097cba1f14b69dca03ff2c714ac470da7200f649c4765543a717a6ce851d1dbd4b0fc8fc84098 WHIRLPOOL 38cacf172047d97ef60cda119ca69bfada8b24687e21d7194c580bfff2def50e84c402223c086c9e870385b465d96556cc4b90ff9a0033937783529cab220be0
diff --git a/dev-python/django-evolution/django-evolution-0.6.9.ebuild b/dev-python/django-evolution/django-evolution-0.6.9.ebuild
new file mode 100644
index 000000000000..fe2e0c4d8d01
--- /dev/null
+++ b/dev-python/django-evolution/django-evolution-0.6.9.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/_}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A Django application that will run cron jobs for other django apps"
+HOMEPAGE="http://code.google.com/p/django-evolution/ http://pypi.python.org/pypi/django_evolution/"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/django[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+ # Fix installing 'tests' package in the global scope.
+ # http://code.google.com/p/django-evolution/issues/detail?id=134
+ sed -i -e 's:find_packages(:&exclude=("tests",):' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # http://code.google.com/p/django-evolution/issues/detail?id=135
+ # This is tested, any delay in die subsequent to (implicitly inherited) multiprocessing eclass
+ "${PYTHON}" tests/runtests.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r docs/
+}
diff --git a/dev-python/django-evolution/django-evolution-0.7.4.ebuild b/dev-python/django-evolution/django-evolution-0.7.4.ebuild
new file mode 100644
index 000000000000..3e463cafbb4b
--- /dev/null
+++ b/dev-python/django-evolution/django-evolution-0.7.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# This is now py3 compatible however is only re'd for Djblets which is py2.7 compat only
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/_}
+MY_P=${MY_PN}-${PV}
+RELEASE="0.7"
+
+DESCRIPTION="A Django application that will run cron jobs for other django apps"
+HOMEPAGE="http://code.google.com/p/django-evolution/ http://pypi.python.org/pypi/django_evolution/"
+SRC_URI="http://downloads.reviewboard.org/releases/${PN}/${RELEASE}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+DOCS=( NEWS docs/{evolution.txt,faq.txt} )
+#DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ # Draws 1 trivial fail under django django-1.4.x
+ "${PYTHON}" tests/runtests.py || die
+}
diff --git a/dev-python/django-evolution/django-evolution-0.7.5.ebuild b/dev-python/django-evolution/django-evolution-0.7.5.ebuild
new file mode 100644
index 000000000000..2906ac8ec47b
--- /dev/null
+++ b/dev-python/django-evolution/django-evolution-0.7.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# This is now py3 compatible however is only re'd for Djblets which is py2.7 compat only
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/_}
+MY_P=${MY_PN}-${PV}
+RELEASE="0.7"
+
+DESCRIPTION="A Django application that will run cron jobs for other django apps"
+HOMEPAGE="http://code.google.com/p/django-evolution/ http://pypi.python.org/pypi/django_evolution/"
+SRC_URI="http://downloads.reviewboard.org/releases/${PN}/${RELEASE}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+DOCS=( NEWS docs/{evolution.txt,faq.txt} )
+
+python_test() {
+ # Draws 1 trivial fail under django django-1.4.x
+ einfo "The testsuite is not compatible with >=django-1.7"
+ "${PYTHON}" tests/runtests.py || die
+}
diff --git a/dev-python/django-evolution/metadata.xml b/dev-python/django-evolution/metadata.xml
new file mode 100644
index 000000000000..51b6135cf7f0
--- /dev/null
+++ b/dev-python/django-evolution/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>idella4@gentoo.org</email>
+ <name>Ian Delaney</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">django_evolution</remote-id>
+ </upstream>
+</pkgmetadata>