summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-06-04 07:46:49 +0100
committerJustin Lecher <jlec@gentoo.org>2017-06-04 08:30:20 +0100
commit1692204d9d7b90e6eea99d0cf53c9cdabe1e3126 (patch)
tree90acb1212ffa7679ccbd27cff4779c941c9a79a9 /dev-python/django-nose/django-nose-1.4.4.ebuild
parentdev-python/dj-database-url: Version Bump (diff)
downloadgentoo-1692204d9d7b90e6eea99d0cf53c9cdabe1e3126.tar.gz
gentoo-1692204d9d7b90e6eea99d0cf53c9cdabe1e3126.tar.bz2
gentoo-1692204d9d7b90e6eea99d0cf53c9cdabe1e3126.zip
dev-python/django-nose: Version Bump
Package-Manager: Portage-2.3.6, Repoman-2.3.2 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/django-nose/django-nose-1.4.4.ebuild')
-rw-r--r--dev-python/django-nose/django-nose-1.4.4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/django-nose/django-nose-1.4.4.ebuild b/dev-python/django-nose/django-nose-1.4.4.ebuild
new file mode 100644
index 000000000000..c9dc45bc70aa
--- /dev/null
+++ b/dev-python/django-nose/django-nose-1.4.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Django test runner that uses nose"
+HOMEPAGE="https://github.com/jbalogh/django-nose"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+#RESTRICT="test" # The testsuite currently broken See notes below
+
+RDEPEND="
+ >=dev-python/nose-1.2.1[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ >=dev-python/dj-database-url-0.3.0[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ ./runtests.sh --verbose || die
+}