summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/django-otp-yubikey
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/django-otp-yubikey')
-rw-r--r--dev-python/django-otp-yubikey/Manifest2
-rw-r--r--dev-python/django-otp-yubikey/django-otp-yubikey-0.2.0.ebuild25
-rw-r--r--dev-python/django-otp-yubikey/django-otp-yubikey-0.3.1.ebuild25
-rw-r--r--dev-python/django-otp-yubikey/metadata.xml12
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/django-otp-yubikey/Manifest b/dev-python/django-otp-yubikey/Manifest
new file mode 100644
index 000000000000..48d651b4e01b
--- /dev/null
+++ b/dev-python/django-otp-yubikey/Manifest
@@ -0,0 +1,2 @@
+DIST django-otp-yubikey-0.2.0.tar.gz 11264 SHA256 72a62d0a0cec9ccf1a1a029b04b6b620f30ec501c0115a52ef6472a6817ba808 SHA512 f0b18fb262caa76a25af0a063c85c07b41f7d211dacd1db2dc6cd55995bc505a1e70535b70a95cba722685a3b34c8a304e9b829b9c3f27caae67921f86f7ffde WHIRLPOOL ccd74c242715cd54436ac451b2d69b8a4a75291ac4f2d05ec3c4ead0dba61329ea720149e369799e3772da97ecc4a70139c0ffb7bf658213072c44b5a2cdc3c9
+DIST django-otp-yubikey-0.3.1.tar.gz 14027 SHA256 584ca85fe05525c04575d760348c1c9adaec24fbab882b3c718a56dbd2f3386b SHA512 d7f13a22f2beb52a8566b5f5b43997344a6ea754bcd06fade0fa39872aad2ba2eecc11b9bccff340e2099c264dcae08faf6beb8d99f0508ae5d67646fcd79204 WHIRLPOOL 90e7cd6b63d322335aa725f30435c222542b4a59e6d7c1c5659ab150a1b00e757b13fdc40cef527e95731499e8f922fd900474bcd70b0b03feb6e06753c5df43
diff --git a/dev-python/django-otp-yubikey/django-otp-yubikey-0.2.0.ebuild b/dev-python/django-otp-yubikey/django-otp-yubikey-0.2.0.ebuild
new file mode 100644
index 000000000000..76647d02c002
--- /dev/null
+++ b/dev-python/django-otp-yubikey/django-otp-yubikey-0.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="django-otp plugin that verifies YubiKey OTP tokens"
+HOMEPAGE="https://bitbucket.org/psagers/django-otp"
+SRC_URI="mirror://pypi/d/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/django-otp[${PYTHON_USEDEP}]
+ dev-python/yubiotp[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/django-otp-yubikey/django-otp-yubikey-0.3.1.ebuild b/dev-python/django-otp-yubikey/django-otp-yubikey-0.3.1.ebuild
new file mode 100644
index 000000000000..f72c43c05040
--- /dev/null
+++ b/dev-python/django-otp-yubikey/django-otp-yubikey-0.3.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="django-otp plugin that verifies YubiKey OTP tokens"
+HOMEPAGE="https://bitbucket.org/psagers/django-otp"
+SRC_URI="mirror://pypi/d/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/django-otp-0.3.0[${PYTHON_USEDEP}]
+ >=dev-python/yubiotp-0.2.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/django-otp-yubikey/metadata.xml b/dev-python/django-otp-yubikey/metadata.xml
new file mode 100644
index 000000000000..c2fc810c4b5e
--- /dev/null
+++ b/dev-python/django-otp-yubikey/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ercpe@gentoo.org</email>
+ <name>Johann Schmitz (ercpe)</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">django-otp-yubikey</remote-id>
+ <remote-id type="bitbucket">psagers/django-otp</remote-id>
+ </upstream>
+</pkgmetadata>