summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-19 13:29:41 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-19 13:29:41 +0200
commit1efac0594d4ffd0c3fa186c429e55a771f710dec (patch)
treeda600bbfae37528dda087f7ebe59e0ab9f461a33 /dev-python/django-otp
parentdev-python/django_polymorphic: Require sqlite for tests (diff)
downloadgentoo-1efac0594d4ffd0c3fa186c429e55a771f710dec.tar.gz
gentoo-1efac0594d4ffd0c3fa186c429e55a771f710dec.tar.bz2
gentoo-1efac0594d4ffd0c3fa186c429e55a771f710dec.zip
dev-python/django-otp: Require sqlite for tests
Closes: https://bugs.gentoo.org/723612 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-otp')
-rw-r--r--dev-python/django-otp/django-otp-0.9.1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/django-otp/django-otp-0.9.1.ebuild b/dev-python/django-otp/django-otp-0.9.1.ebuild
index 4bbf7d96389b..cb3c87c6043b 100644
--- a/dev-python/django-otp/django-otp-0.9.1.ebuild
+++ b/dev-python/django-otp/django-otp-0.9.1.ebuild
@@ -21,7 +21,11 @@ RESTRICT="!test? ( test )"
RDEPEND="
>=dev-python/django-1.11[${PYTHON_USEDEP}]"
-BDEPEND="test? ( ${RDEPEND} )"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ ${RDEPEND}
+ )"
python_test() {
local -x PYTHONPATH=test:${PYTHONPATH}