summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-21 13:07:14 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-21 13:24:21 +0200
commit29478a15af17d60d1ff9f49e46cf6fee6799bc9e (patch)
tree1b32aed823a6dd935e22b40a3fb0a70d9b446539 /dev-python/django-otp
parentpackage.mask: Last rite dev-python/django-durationfield (diff)
downloadgentoo-29478a15af17d60d1ff9f49e46cf6fee6799bc9e.tar.gz
gentoo-29478a15af17d60d1ff9f49e46cf6fee6799bc9e.tar.bz2
gentoo-29478a15af17d60d1ff9f49e46cf6fee6799bc9e.zip
dev-python/django-otp: Bump to 0.9.0, py3.{7,8}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-otp')
-rw-r--r--dev-python/django-otp/Manifest1
-rw-r--r--dev-python/django-otp/django-otp-0.9.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/django-otp/Manifest b/dev-python/django-otp/Manifest
index f45cdc8646a2..7ee064d8e4cf 100644
--- a/dev-python/django-otp/Manifest
+++ b/dev-python/django-otp/Manifest
@@ -1 +1,2 @@
DIST django-otp-0.4.3.tar.gz 42480 BLAKE2B 09398e4e06425fefdda45a3a200576efda9409a42fb8f1c640a996e066e1ad2cf47e6ee0879e4a61cdc64808fe8f030aba19dfd99fa4da7d3e86597bda881d09 SHA512 3f3ec761dc12ed40e8c757dfbe1fd951c7c6aed3abc311c823acdeca08d5864b54c8442a49807228be17b30c20093b1ba7fb8b2c0f86f00dc1cc215ccd7c28de
+DIST django-otp-0.9.0.gh.tar.gz 60204 BLAKE2B c71b27e007580410fea3cf8110631801c8c08f7e325c3586cb5a41a9618b371b5d65e3b030a5b483cb6cda684fe837cd40aa1c5d04f54dc82cda750b8ba8aeb9 SHA512 dd3c99e928ebf1ba5b6f6b2f34fcf8a1f86ad64ece17a9bd97c56be239f165808f6d1025e2826a12a8eadc150fe49920a0b7ef398d83542cd97a4a6f391505fe
diff --git a/dev-python/django-otp/django-otp-0.9.0.ebuild b/dev-python/django-otp/django-otp-0.9.0.ebuild
new file mode 100644
index 000000000000..4bbf7d96389b
--- /dev/null
+++ b/dev-python/django-otp/django-otp-0.9.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django framework adding two-factor authentication using one-time passwords"
+HOMEPAGE="https://github.com/django-otp/django-otp/"
+SRC_URI="
+ https://github.com/django-otp/django-otp/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-1.11[${PYTHON_USEDEP}]"
+BDEPEND="test? ( ${RDEPEND} )"
+
+python_test() {
+ local -x PYTHONPATH=test:${PYTHONPATH}
+ local -x DJANGO_SETTINGS_MODULE=test_project.settings
+ django-admin test -v 2 django_otp || die "Tests fail with ${EPYTHON}"
+}