summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-29 08:51:39 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-29 10:06:35 +0200
commiteb6f6d09594b7b0d7cf2baf51443f9e3a047e7a7 (patch)
tree75a0a8216b692be07a0b7b5eb405f978caaf44ce /dev-python/django-otp
parentdev-ruby/parser: add ruby30 (diff)
downloadgentoo-eb6f6d09594b7b0d7cf2baf51443f9e3a047e7a7.tar.gz
gentoo-eb6f6d09594b7b0d7cf2baf51443f9e3a047e7a7.tar.bz2
gentoo-eb6f6d09594b7b0d7cf2baf51443f9e3a047e7a7.zip
dev-python/django-otp: Bump to 1.0.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-otp')
-rw-r--r--dev-python/django-otp/Manifest1
-rw-r--r--dev-python/django-otp/django-otp-1.0.6.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/django-otp/Manifest b/dev-python/django-otp/Manifest
index 291a0959abde..2964f53552b9 100644
--- a/dev-python/django-otp/Manifest
+++ b/dev-python/django-otp/Manifest
@@ -2,3 +2,4 @@ DIST django-otp-1.0.2.gh.tar.gz 66885 BLAKE2B be98b68f0aa5df25835afa28a23d25e035
DIST django-otp-1.0.3.gh.tar.gz 67007 BLAKE2B 33aed04898afb6ad3940e06436a1d2b4b9349e8fcd55acba0719084939fb9b111e0c266f4964826491f91f832c16f2e4d505486016bfad416706e3e7ef6f3f37 SHA512 7b661228377fa57812a45888e415478cee49d1e343cbc814ba8631f4c354077901ec82f79e69abd00c6bad1dffa026d3e03f4cf0809b074ae1e02ab2cf878137
DIST django-otp-1.0.4.gh.tar.gz 68976 BLAKE2B 30908c3769ca9c05c850524d8a3b155f7ac8fcfa8e69073622d83808d7b78293604f9b332e59b074a6737188ca4f53ede13d31d283588605ca17f994bf5d4e5e SHA512 7b37fbc56a708f5c26e6204fba344235c7823db66d7e3e56b74516efc8a1de4150c088ce2d94c04c10855f438b077599d361a4d2c2263e8ff2936309dc0ddb6e
DIST django-otp-1.0.5.gh.tar.gz 68677 BLAKE2B fd4fe66695faf4a75fc9cdab69241520c42c50d013121375bed2cb0f04a71def8e64588e3ac5727cfb319cb025273cb5adfd5d3b0dbab06590967c58e2b36e37 SHA512 bfdfe6d5058a6bead28a756392a76301cb821b5ea4f61dff8d376aa7732aa92bf8d709cb964d23e94ed37ec0e3ae45768f4fc4a98aaabfb2be0788bb0059f10c
+DIST django-otp-1.0.6.gh.tar.gz 69023 BLAKE2B 82534fb666e27ab654b1587160fd9fd4600d1ecb57f5b506b383c3d7b36a13d6bbff39598603c7c3bc69edc871a6a3ad1aa2531a92ea921ab07798e7e4bb1316 SHA512 ff14a786bc8b3d22c8767fa78d676951c262389dfe00def981c79894d299f393ffc86510c33866482aa246ac1643238a3de5701bb76cf56aea5e3ba0a25cbb97
diff --git a/dev-python/django-otp/django-otp-1.0.6.ebuild b/dev-python/django-otp/django-otp-1.0.6.ebuild
new file mode 100644
index 000000000000..26c9a4b8f2af
--- /dev/null
+++ b/dev-python/django-otp/django-otp-1.0.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django framework adding two-factor authentication using one-time passwords"
+HOMEPAGE="https://github.com/django-otp/django-otp/"
+SRC_URI="
+ https://github.com/django-otp/django-otp/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )"
+
+python_test() {
+ local -x PYTHONPATH=test:${PYTHONPATH}
+ local -x DJANGO_SETTINGS_MODULE=test_project.settings
+ django-admin test -v 2 django_otp || die "Tests fail with ${EPYTHON}"
+}