summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/django-piston
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/django-piston')
-rw-r--r--dev-python/django-piston/Manifest1
-rw-r--r--dev-python/django-piston/django-piston-0.2.3-r1.ebuild22
-rw-r--r--dev-python/django-piston/django-piston-9999.ebuild24
-rw-r--r--dev-python/django-piston/metadata.xml13
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/django-piston/Manifest b/dev-python/django-piston/Manifest
new file mode 100644
index 000000000000..c18b3ee9bd56
--- /dev/null
+++ b/dev-python/django-piston/Manifest
@@ -0,0 +1 @@
+DIST django-piston-0.2.3.tar.gz 34319 SHA256 fb015137ceb7934f4645f7eb91a05d7bd63ef6bb1bd84f557ce55fac38e38ae9 SHA512 205cb15b4e59e7cb4d744525e149480ce9f54afa6b514c038ecf20df9221b4193d5041963b7217f40454c34d77125a1e52f0e7bfed5a471b27b1694a3af2ef6a WHIRLPOOL 364c8273a7542c43e18059b9c0ea6a110577ae190d2faa8cb268045556cf9d1882771ae05d907c907467562994be1367435c498329515d554eb675618f3bc50f
diff --git a/dev-python/django-piston/django-piston-0.2.3-r1.ebuild b/dev-python/django-piston/django-piston-0.2.3-r1.ebuild
new file mode 100644
index 000000000000..63558b51ce1e
--- /dev/null
+++ b/dev-python/django-piston/django-piston-0.2.3-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A mini-framework for Django for creating RESTful APIs"
+HOMEPAGE="http://bitbucket.org/jespern/django-piston/wiki/Home"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/django-piston/django-piston-9999.ebuild b/dev-python/django-piston/django-piston-9999.ebuild
new file mode 100644
index 000000000000..6e4947ce4133
--- /dev/null
+++ b/dev-python/django-piston/django-piston-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 mercurial
+
+DESCRIPTION="A mini-framework for Django for creating RESTful APIs"
+HOMEPAGE="http://bitbucket.org/jespern/django-piston/wiki/Home"
+EHG_REPO_URI="http://bitbucket.org/jespern/django-piston/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${PN}"
diff --git a/dev-python/django-piston/metadata.xml b/dev-python/django-piston/metadata.xml
new file mode 100644
index 000000000000..dedfa7e1286a
--- /dev/null
+++ b/dev-python/django-piston/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">django-piston</remote-id>
+ <remote-id type="bitbucket">jespern/django-piston</remote-id>
+ </upstream>
+</pkgmetadata>