summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-08 08:48:40 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-08 08:55:29 +0200
commit40798293a378bb6890eedf0ab9bd2063a0cf2ed5 (patch)
treeae107a50926059ad1e2e71124e8a298ddaf6880e /dev-python/django-timezone-field
parentdev-python/djangorestframework: Port to py3.10 (diff)
downloadgentoo-40798293a378bb6890eedf0ab9bd2063a0cf2ed5.tar.gz
gentoo-40798293a378bb6890eedf0ab9bd2063a0cf2ed5.tar.bz2
gentoo-40798293a378bb6890eedf0ab9bd2063a0cf2ed5.zip
dev-python/django-timezone-field: Bump to 4.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-timezone-field')
-rw-r--r--dev-python/django-timezone-field/Manifest1
-rw-r--r--dev-python/django-timezone-field/django-timezone-field-4.2.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/django-timezone-field/Manifest b/dev-python/django-timezone-field/Manifest
index 3d8e03c30bd1..c4c4246129fd 100644
--- a/dev-python/django-timezone-field/Manifest
+++ b/dev-python/django-timezone-field/Manifest
@@ -1 +1,2 @@
DIST django-timezone-field-4.1.tar.gz 8286 BLAKE2B 591a3d9a332102fd6b3a3cf865b1b9ca2ef1d7b37f6bc1a01ddc724050468d59ee5b6c14933203b6182a5efddad32e7e76b17980e415562404057b0e25393089 SHA512 3903e19ab66d636a4fa9c0364aa8232958c6b0d33c41253d57322320543e8f4993ff1eac2fdbee319b174e7e85fbb2dece9cd8db910913d4249de9eb862917e2
+DIST django-timezone-field-4.2.1.gh.tar.gz 23457 BLAKE2B 72452a21e6e086363da2ef40389d12b79860f66706e54fb9050ffe48f7fa6ad2908c75d4c7e17a79df339eac76492599dd4533ddca69a5b8757b46a36ed4b0fc SHA512 4c2da420c3aaffa23d8cdb66dbbe4b2ea8638de5a45d9e381bf9af980e52eba77fc03a2b8fee8497662199cdc9436d56543c0f6316e74ae5da68187a305c34a2
diff --git a/dev-python/django-timezone-field/django-timezone-field-4.2.1.ebuild b/dev-python/django-timezone-field/django-timezone-field-4.2.1.ebuild
new file mode 100644
index 000000000000..0e61159b2c1e
--- /dev/null
+++ b/dev-python/django-timezone-field/django-timezone-field-4.2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A Django app providing database and form fields for pytz timezone objects"
+HOMEPAGE="https://github.com/mfogel/django-timezone-field"
+SRC_URI="
+ https://github.com/mfogel/django-timezone-field/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/djangorestframework[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x DB_ENGINE=sqlite
+ epytest
+}