summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-21 13:53:01 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-21 15:35:01 +0200
commit2fa43f10a72d5439635220dcf9a10a0de635c75f (patch)
tree7c298656d20cd300db9965ea4be4e99b9e036d8c /dev-python/django_polymorphic/django_polymorphic-3.0.0.ebuild
parentdev-python/dj-database-url: Port to py3.9 (diff)
downloadgentoo-2fa43f10a72d5439635220dcf9a10a0de635c75f.tar.gz
gentoo-2fa43f10a72d5439635220dcf9a10a0de635c75f.tar.bz2
gentoo-2fa43f10a72d5439635220dcf9a10a0de635c75f.zip
dev-python/django_polymorphic: Bump to 3.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django_polymorphic/django_polymorphic-3.0.0.ebuild')
-rw-r--r--dev-python/django_polymorphic/django_polymorphic-3.0.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/django_polymorphic/django_polymorphic-3.0.0.ebuild b/dev-python/django_polymorphic/django_polymorphic-3.0.0.ebuild
new file mode 100644
index 000000000000..db4810c125f8
--- /dev/null
+++ b/dev-python/django_polymorphic/django_polymorphic-3.0.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Seamless Polymorphic Inheritance for Django Models"
+HOMEPAGE="https://pypi.org/project/django-polymorphic/"
+SRC_URI="https://github.com/django-polymorphic/django-polymorphic/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P//_/-}"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-2.1[$PYTHON_USEDEP]
+"
+
+DEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ ${RDEPEND}
+ dev-python/dj-database-url[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ "${EPYTHON}" runtests.py || die "Tests fail with ${EPYTHON}"
+}