summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-08-05 13:05:34 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-08-05 13:05:34 +0200
commit3acbd46386aa68f85dfe8d50667680703a5703eb (patch)
treef168f9fa9f160193e7aba352fbff0adf311537a4 /dev-python/dnspython
parentsys-cluster/kube-proxy: Version bump to 1.9.10 (diff)
downloadgentoo-3acbd46386aa68f85dfe8d50667680703a5703eb.tar.gz
gentoo-3acbd46386aa68f85dfe8d50667680703a5703eb.tar.bz2
gentoo-3acbd46386aa68f85dfe8d50667680703a5703eb.zip
dev-python/dnspython: Snapshot that supports pycryptodome
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'dev-python/dnspython')
-rw-r--r--dev-python/dnspython/Manifest1
-rw-r--r--dev-python/dnspython/dnspython-1.16.0_pre20180731.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/dnspython/Manifest b/dev-python/dnspython/Manifest
index f547dd89ee4b..23080a5bc5f8 100644
--- a/dev-python/dnspython/Manifest
+++ b/dev-python/dnspython/Manifest
@@ -1 +1,2 @@
DIST dnspython-1.15.0.zip 252157 BLAKE2B 6766c1e69bc4225b08f3b1b3871fac2aba7ae707de5f16718798ce4d6846308500c5341f9ace1b48d3858ffc965a7295ee42cc2c35ff23ac38d71927dcaecfe9 SHA512 942f7cf083d1b0a9f03f040ceca194c38777f2e40862c388051986112b3f2a4a8426733ff46ec5a155319776e4a856412c3430b052b2f92f251f0e3260eb9bc1
+DIST dnspython-1.16.0_pre20180731.tar.gz 182538 BLAKE2B 3a472091fccc4f37d65681727643677472837fd6be0c4fd6aaa13afd1fd4362eb27a5ba4ff6babca46fe15c2f5318ddbba22ce058b522f763baa797e1e2d1ab9 SHA512 67d17ab7cb48c370c3c2dd5cb935eec5ab7e3ac0c912e179931f395899ad186ba869edd8b870c043ba9fb3545bace18549d2a377f2ae2c278660fc488e68a20d
diff --git a/dev-python/dnspython/dnspython-1.16.0_pre20180731.ebuild b/dev-python/dnspython/dnspython-1.16.0_pre20180731.ebuild
new file mode 100644
index 000000000000..1d9163245a63
--- /dev/null
+++ b/dev-python/dnspython/dnspython-1.16.0_pre20180731.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 vcs-snapshot
+
+GIT_COMMIT="be7e71e54a6edc87ead1b15af8981b8921e0e83d"
+
+DESCRIPTION="DNS toolkit for Python"
+HOMEPAGE="http://www.dnspython.org/ https://pypi.org/project/dnspython/"
+SRC_URI="https://github.com/rthalley/dnspython/archive/${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="examples test"
+
+RDEPEND="dev-python/pycryptodome[${PYTHON_USEDEP}]
+ >=dev-python/ecdsa-0.13[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.1[${PYTHON_USEDEP}]
+ !dev-python/dnspython:py2
+ !dev-python/dnspython:py3"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# For testsuite
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ cd tests || die
+ "${PYTHON}" utest.py || die "tests failed under ${EPYTHON}"
+ einfo "Testsuite passed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}